Lookup gzdoom pk3 files in the installed directory in addition to the path that is stored in ~/.config/gzdoom/. Simply replacing the hardcoded /usr/share would leave the configfile pointing to outdated guix builds, which could get garbage collected and break the gzdoom installation. This ensures that the files installed with the corresponding build will be used. --- /src/d_main.cpp 2018-01-16 22:13:09.700602781 +0200 +++ /src/d_main.cpp 2018-01-16 22:22:36.560617961 +0200 @@ -1716,6 +1716,11 @@ return wad; } + mysnprintf (wad, countof(wad), "%s/%s", GUIX_OUT_PK3, file); + if (DirEntryExists (wad)) { + return wad; + } + if (GameConfig != NULL && GameConfig->SetSection ("FileSearch.Directories")) { const char *key; ion value='koszko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/pack.scm
t-desktop.tmpl: Complete i3-wm....
AgeCommit message (Expand)Author
2018-11-06store-copy: Canonicalize the mtime and permissions of the store copy....Ludovic Courtès
2018-11-06pack: Add test for 'self-contained-tarball' with localstatedir....Ludovic Courtès
2018-11-06pack: Squashfs backend now honors '--localstatedir'....Ludovic Courtès
2018-11-06pack: Docker backend now honors '--localstatedir'....Ludovic Courtès
2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès
2018-10-28tests: Fix typo....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-09-18tests: Skip 'self-contained-tarball' test unconditionally....Ludovic Courtès
2018-06-01pack: Adjust test to expect relative symlinks....Ludovic Courtès
2018-06-01tests: Fix arguments in pack test....Ricardo Wurmus
Leo Famulari
2017-02-13system: Use the normalized codeset for the locale name in the examples....Ludovic Courtès