Lookup gzdoom pk3 files in the installed directory in
addition to the path that is stored in ~/.config/gzdoom/.
Simply replacing the hardcoded /usr/share would leave the
configfile pointing to outdated guix builds, which could get
garbage collected and break the gzdoom installation.
This ensures that the files installed with the corresponding
build will be used.
--- /src/d_main.cpp 2018-01-16 22:13:09.700602781 +0200
+++ /src/d_main.cpp 2018-01-16 22:22:36.560617961 +0200
@@ -1716,6 +1716,11 @@
return wad;
}
+ mysnprintf (wad, countof(wad), "%s/%s", GUIX_OUT_PK3, file);
+ if (DirEntryExists (wad)) {
+ return wad;
+ }
+
if (GameConfig != NULL && GameConfig->SetSection ("FileSearch.Directories"))
{
const char *key;
ed='selected'>koszko
etc: Default to variables in tempel's git-reference... et al....Since we encourage using variables rather than magic hashes in the commit
fields, e.g. (commit version) and (commit commit), the default for
tempel to use quoted strings is rather off. Thus, let the placeholder reflect
actual usage.
* etc/snippets/tempel/scheme-mode (git-reference...)[commit]: Use field name
as placeholder and don't quote value.
(svn-reference..., bzr-reference...)[revision]: Likewise.
(hg-reference...)[changeset]: Likewise.
Liliana Marie Prikler
2022-08-30
etc: Add tempel snippet for :phases....* etc/snippets/tempel/scheme-mode (:phases, add-before\ , add-after\ )
(replace\ ): New snippets.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Nicolas Graves
2022-08-30
etc: Add tempel snippets....* etc/snippets/tempel/scheme-mode: New file.
* etc/snippets/tempel/text-mode: New file.
* etc/snippets/scheme-mode: Moved from here...
* etc/snippets/yas/scheme-mode: ... to here.
* etc/snippets/text-mode: Moved from here...
* etc/snippets/yas/text-mode: ... to here.
* doc/contributing.texi ("The Perfect Setup"): Adjust yasnippet setup
accordingly. Add tempel setup.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>