Lookup gzdoom pk3 files in the installed directory in addition to the path that is stored in ~/.config/gzdoom/. Simply replacing the hardcoded /usr/share would leave the configfile pointing to outdated guix builds, which could get garbage collected and break the gzdoom installation. This ensures that the files installed with the corresponding build will be used. --- /src/d_main.cpp 2018-01-16 22:13:09.700602781 +0200 +++ /src/d_main.cpp 2018-01-16 22:22:36.560617961 +0200 @@ -1716,6 +1716,11 @@ return wad; } + mysnprintf (wad, countof(wad), "%s/%s", GUIX_OUT_PK3, file); + if (DirEntryExists (wad)) { + return wad; + } + if (GameConfig != NULL && GameConfig->SetSection ("FileSearch.Directories")) { const char *key; > Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/nfs.scm
AgeCommit message (Expand)Author
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-04-10tests: nfs: Fix typo in description....Tobias Geerinckx-Rice
2020-11-07tests: nfs-root-fs: Use the right store file name....Ludovic Courtès
2020-09-10tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-07tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-07tests: Add "nfs-root-fs" system test....Stefan
2020-03-25tests/nfs: Fix use of WAIT-FOR-FILE....Ricardo Wurmus
2020-03-16tests: nfs-server: Use marionette helper procedures....Ludovic Courtès
2020-03-16tests: nfs: Ensure 'rpcinfo' can be found....Ludovic Courtès
2020-01-08services: nfs: Add nfs-service-type....Ricardo Wurmus