This patch has been proposed upstream: https://lists.systemreboot.net/guile-email/87mtnv1r2p.fsf@gnu.org/T/#u. From c21fe0f0e28b80b606973d3e372e2bc8528c9766 Mon Sep 17 00:00:00 2001 From: Mathieu Othacehe Date: Wed, 29 Sep 2021 12:47:35 +0000 Subject: [PATCH 1/1] email: Do not use an empty bytevector to test the charset. Using an empty bytevector no longer throws an exception since this Guile commit: 5ea8c69e9153a970952bf6f0b32c4fad6a28e839. * email/email.scm (post-process-content-transfer-encoding): Use a bytevector containg the 'e' character to test the charset validity. --- email/email.scm | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/email/email.scm b/email/email.scm index 3f4e194..ac70463 100644 --- a/email/email.scm +++ b/email/email.scm @@ -832,7 +832,8 @@ values. The returned headers is a string and body is a bytevector." (define (valid-charset? charset) (catch #t (lambda () - (bytevector->string (make-bytevector 0 0) charset) + ;; Try to convert a bytevector containg the 'e' character. + (bytevector->string (make-bytevector 1 48) charset) #t) (const #f))) -- 2.33.0 0c0e7cb2faee5b394'>refslogtreecommitdiff
path: root/etc/snippets/scheme-mode
af4733. * guix.scm: Use #:re-export-and-replace for 'define-public'. /a>...* gnu/packages/node-xyz.scm (node-oop): New variable.
AgeCommit message (Collapse)Author
2019-05-09Add (guix bzr-download).Maxim Cournoyer
* guix/bzr-download.scm, guix/build/bzr.scm, etc/snippets/scheme-mode/guix-bzr-reference: New files. * Makefile.am (MODULES): Add them. * etc/snippets/scheme-mode/guix-origin: Add "bzr-fetch" to the origin choices.
2021-06-29(guix) no longer pulls in (guix ftp-client).Ludovic Courtès
That choice was made in 2014 and never made much sense. * guix.scm (%public-modules): Remove 'ftp-client'.
Efraim Flashner
2020-01-20gnu: Add node-util-deprecate....* gnu/packages/node-xyz.scm (node-util-deprecate): New variable. Efraim Flashner
2020-01-20gnu: Add node-statsd-parser....* gnu/packages/node-xyz.scm (node-statsd-parser): New variable. Efraim Flashner
2020-01-20gnu: Add node-mersenne....* gnu/packages/node-xyz.scm (node-mersenne): New variable. Efraim Flashner
2020-01-20gnu: Add node-long-stack-traces....* gnu/packages/node-xyz.scm (node-long-stack-traces): New variable. Efraim Flashner
2020-01-20gnu: Add node-env-variable....* gnu/packages/node-xyz.scm (node-env-variable): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it. Efraim Flashner