Two patches here backporting fixes from Emacs master. Upstream status: emailed first patch to latest committer, Robin Templeton , no response. From dfcb3b6ff318e47b84a28cfc43f50bec42fa3570 Mon Sep 17 00:00:00 2001 From: Jan Nieuwenhuizen Date: Tue, 7 Nov 2017 18:48:03 +0100 Subject: [PATCH 1/2] backport: Port jpeg configuration to Solaris 10 with Sun C. * configure.ac: Check for jpeglib 6b by trying to link it, instead of relying on cpp magic that has problems in practice. Check for both jpeglib.h and jerror.h features. Remove special case for mingw32, which should no longer be needed (and if it were needed, should now be addressable by hotwiring emacs_cv_jpeglib). Fixes: bug#20332 From fdf532b9c915ad9ba72155646d29d0f530fd72ec Mon Sep 17 00:00:00 2001 From: Paul Eggert Date: Wed, 15 Apr 2015 18:30:01 -0700 Subject: [PATCH] Port jpeg configuration to Solaris 10 with Sun C. * configure.ac: Che
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:40 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:49 +0200
commit570a4c77f892c4f625c0c638084a0549cb17bc58 (patch)
treed46d5abe640382705356b8bc0745bbe8e45c7512 /configure.ac
parent83706ea9e91792f22eec900ff65372c49991297f (diff)
downloadguix-570a4c77f892c4f625c0c638084a0549cb17bc58.tar.gz
guix-570a4c77f892c4f625c0c638084a0549cb17bc58.zip
gnu: Add python-easyprocess.
* gnu/packages/python-xyz.scm (python-easyprocess): New variable.
Diffstat (limited to 'configure.ac')
0 files changed, 0 insertions, 0 deletions
+hybrid_malloc= +system_malloc=yes + +test "$CANNOT_DUMP" = yes || +case "$opsys" in + ## darwin ld insists on the use of malloc routines in the System framework. + darwin | mingw32 | nacl | sol2-10) ;; + cygwin) hybrid_malloc=yes + system_malloc= ;; + *) test "$ac_cv_func_sbrk" = yes && system_malloc=$emacs_cv_sanitize_address;; +esac + +if test "${system_malloc}" != yes && test "${doug_lea_malloc}" != yes \ + && test "${UNEXEC_OBJ}" = unexelf.o; then + hybrid_malloc=yes +fi + GMALLOC_OBJ= +HYBRID_MALLOC= if test "${system_malloc}" = "yes"; then AC_DEFINE([SYSTEM_MALLOC], 1, [Define to 1 to use the system memory allocator, even if it is not @@ -1975,6 +1993,14 @@ if test "${system_malloc}" = "yes"; then GNU_MALLOC_reason=" (The GNU allocators don't work with this system configuration.)" VMLIMIT_OBJ= +elif test "$hybrid_malloc" = yes; then + AC_DEFINE(HYBRID_MALLOC, 1, + [Define to use gmalloc before dumping and the system malloc after.]) + HYBRID_MALLOC=1 + GNU_MALLOC=no + GNU_MALLOC_reason=" (only before dumping)" + GMALLOC_OBJ=gmalloc.o + VMLIMIT_OBJ= else test "$doug_lea_malloc" != "yes" && GMALLOC_OBJ=gmalloc.o VMLIMIT_OBJ=vm-limit.o @@ -1993,10 +2019,11 @@ else of the main data segment.]) fi fi +AC_SUBST([HYBRID_MALLOC]) AC_SUBST(GMALLOC_OBJ) AC_SUBST(VMLIMIT_OBJ) -if test "$doug_lea_malloc" = "yes" ; then +if test "$doug_lea_malloc" = "yes" && test "$hybrid_malloc" != yes; then if test "$GNU_MALLOC" = yes ; then GNU_MALLOC_reason=" (Using Doug Lea's new malloc from the GNU C Library.)" -- Jan Nieuwenhuizen | GNU LilyPond http://lilypond.org Freelance IT http://JoyofSource.com | AvatarĀ® http://AvatarAcademy.com