Submitted upstream: https://gitlab.com/weinholt/ac-d-bus/-/merge_requests/3
diff --git a/tests/test-signature.sps b/tests/test-signature.sps
index 278401b..cc5574f 100755
--- a/tests/test-signature.sps
+++ b/tests/test-signature.sps
@@ -43,6 +43,7 @@
(format-type-signature '(message BYTE BYTE BYTE BYTE UINT32 UINT32
(ARRAY (STRUCT BYTE VARIANT)))))
+(define fail-count (test-runner-fail-count (test-runner-get)))
(test-end)
-(exit (if (zero? (test-runner-fail-count (test-runner-get))) 0 1))
+(exit (if (zero? fail-count) 0 1))
diff --git a/tests/test-wire.sps b/tests/test-wire.sps
index c3354bf..06ae73b 100755
--- a/tests/test-wire.sps
+++ b/tests/test-wire.sps
@@ -147,6 +147,7 @@
#x08 #x01 #x67 #x00 #x00 #x00 #x00 #x00 #x05 #x01 #x75 #x00 #x04 #x00 #x00 #x00
#x07 #x01 #x73 #x00 #x06 #x00 #x00 #x00 #x3A #x31 #x2E #x32 #x39 #x38 #x00 #x00)))
+(define fail-count (test-runner-fail-count (test-runner-get)))
(test-end)
-(exit (if (zero? (test-runner-fail-count (test-runner-get))) 0 1))
+(exit (if (zero? fail-count) 0 1))
href='/guix/log/.patman'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-10-22 | gnu: patman: Apply patch for new Change-Id setting....* gnu/packages/bootloaders.scm (u-boot) [source]: Apply patch.
* gnu/packages/patches/u-boot-patman-change-id.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* .patman (keep_change_id): Use it.
Series-changes: 3
- New commit
Change-Id: I33c03013f6a260b5f5d80212b7b6ebe8a3f97efa
| Maxim Cournoyer |
2023-05-01 | .patman: Remove get_maintainer_script option....This is now handled at the level of git via its new '--header-cmd' option,
which produces X-Debbugs-CC headers.
* .patman (get_maintainer_script): Delete option.
| Maxim Cournoyer |
2023-02-25 | .patman: Ignore bad tags....The feature is not used in Guix, and it produces extraneous warnings.
* .patman (ignore_bad_tags): Set option to True.
| Maxim Cournoyer |
2022-12-28 | .patman: New configuration file....* .patman: New file.
Series-to: 60218@debbugs.gnu.org
Series-cc: rekado@elephly.net, othacehe@gnu.org
Series-version: 2
| Maxim Cournoyer |