Skip 'test-stack-overflow' that crashes when using QEMU transparent emulation.
--- a/test-suite/standalone/Makefile.in 1970-01-01 01:00:01.000000000 +0100
+++ b/test-suite/standalone/Makefile.in 2021-01-11 10:59:31.606269449 +0100
@@ -102,8 +102,7 @@
test-scm-to-latin1-string$(EXEEXT) test-scm-values$(EXEEXT) \
test-scm-c-bind-keyword-arguments$(EXEEXT) \
test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
- test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
- test-stack-overflow
+ test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT)
check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
@@ -1938,7 +1937,7 @@
test-command-line-encoding test-command-line-encoding2 \
test-language test-guild-compile $(am__append_3) \
test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
- test-use-srfi $(am__append_5) test-stack-overflow
+ test-use-srfi $(am__append_5)
BUILT_SOURCES = $(am__append_2)
EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
test-import-order-c.scm test-import-order-d.scm \
href='/guix/refs/?id=9a141b5bd633227ea31776b9ce7ca40928de2442'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: glibc: Fix locpath patches....* gnu/packages/patches/glibc-2.37-versioned-locpath.patch:
* gnu/packages/patches/glibc-versioned-locpath.patch: Unconditionally add the
system default locale directory. Also clean up argz list use.
Change-Id: I8de5544b2382ee9b17d41ad2cfe940de804c47dd
| Josselin Poiret |
2024-08-31 | gnu: glibc: Ensure C.UTF-8 locale is always found....This change ensures that $prefix/lib/locale, which now contains C.UTF-8
data, is always searched. Thus, “setlocale (LC_ALL, "C.UTF-8")” is
guaranteed to always succeed.
* gnu/packages/patches/glibc-2.37-versioned-locpath.patch: Adjust.
Change-Id: I6aaf2757da98e811aa55e0959126065537cd8970
| Ludovic Courtès |
2024-08-31 | gnu: glibc: Update to 2.38....* gnu/packages/patches/glibc-2.38-ldd-x86_64.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/base.scm (glibc): Update to 2.38.
[source]: Adjust list of patches.
[arguments]: Add ‘--enable-crypt’.
(glibc-2.35): New variable.
Change-Id: I040b724c47d2ee5f90f2deb03a4828e79d1bfc4e
| Ludovic Courtès |