Fix doc snarfing with GCC 4.5+. From . diff --git a/scripts/snarf-check-and-output-texi b/scripts/snarf-check-and-output-texi index ea33e17..8cd42e8 100755 --- a/scripts/snarf-check-and-output-texi +++ b/scripts/snarf-check-and-output-texi @@ -267,6 +267,17 @@ exec ${GUILE-guile} -l $0 -c "(apply $main (cdr (command-line)))" "$@" (set! *file* file) (set! *line* line)) + ;; newer gccs like to throw around more location markers into the + ;; preprocessed source; these (hash . hash) bits are what they translate to + ;; in snarfy terms. + (('location ('string . file) ('int . line) ('hash . 'hash)) + (set! *file* file) + (set! *line* line)) + + (('location ('hash . 'hash) ('string . file) ('int . line) ('hash . 'hash)) + (set! *file* file) + (set! *line* line)) + (('arglist rest ...) (set! *args* (do-arglist rest))) lass='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
AgeCommit message (Expand)Author
2022-04-20gnu: aws-lc: Update to 1.0.2....* gnu/packages/tls.scm (aws-lc): Update to 1.0.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan
2022-04-20gnu: s2n: Update to 1.3.10....* gnu/packages/tls.scm (s2n): Update to 1.3.10. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan
2022-04-12gnu: libressl: Update to 3.3.6....* gnu/packages/tls.scm (libressl): Update to 3.3.6. Liliana Marie Prikler
2022-04-01gnu: libressl: Add 'release-monitoring-url' property....* gnu/packages/tls.scm (libressl)[properties]: New field. Ludovic Courtès
2022-03-16gnu: OpenSSL 3: Update to 3.0.2 [fixes CVE-2022-0778]....For more information about this vulnerability: https://www.openssl.org/news/secadv/20220315.txt * gnu/packages/tls.scm (openssl-3.0): Update to 3.0.2. Leo Famulari
2022-03-16gnu: OpenSSL: Update to 1.1.1n [fixes CVE-2022-0778]....For more information about this vulnerability: https://www.openssl.org/news/secadv/20220315.txt * gnu/packages/tls.scm (openssl/fixed): Update to 1.1.1n. Leo Famulari
2022-01-30gnu: Remove OpenSSL 1.0....This package no longer has any users in Guix. * gnu/packages/tls.scm (openssl-1.0): Remove variable. Marius Bakke
2022-01-30gnu: OpenSSL: Add 3.0....* gnu/packages/tls.scm (openssl-3.0): New variable. * gnu/packages/patches/openssl-3.0-c-rehash-in.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Marius Bakke
2022-01-26gnu: openssl: Update to 1.1.1m [security fixes]....* gnu/packages/tls.scm (openssl/fixed): New variable. (openssl)[replacement]: New field. Efraim Flashner
2022-01-18gnu: Add bearssl....* gnu/packages/tls.scm (bearssl): New variable. Nicolas Goaziou
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès