Fix doc snarfing with GCC 4.5+. From . diff --git a/scripts/snarf-check-and-output-texi b/scripts/snarf-check-and-output-texi index ea33e17..8cd42e8 100755 --- a/scripts/snarf-check-and-output-texi +++ b/scripts/snarf-check-and-output-texi @@ -267,6 +267,17 @@ exec ${GUILE-guile} -l $0 -c "(apply $main (cdr (command-line)))" "$@" (set! *file* file) (set! *line* line)) + ;; newer gccs like to throw around more location markers into the + ;; preprocessed source; these (hash . hash) bits are what they translate to + ;; in snarfy terms. + (('location ('string . file) ('int . line) ('hash . 'hash)) + (set! *file* file) + (set! *line* line)) + + (('location ('hash . 'hash) ('string . file) ('int . line) ('hash . 'hash)) + (set! *file* file) + (set! *line* line)) + (('arglist rest ...) (set! *args* (do-arglist rest))) class='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/xorg.scm
AgeCommit message (Expand)Author
2024-05-30services: xorg: Add startx-command-service-type....Tomas Volf
2024-05-30services: xorg: Add xorg-start-command-xinit procedure....Tomas Volf
2024-04-28services: gdm: Use ‘make-forkexec-constructor’....Ludovic Courtès
2024-03-20Merge remote-tracking branch 'savannah/master' into gnome-team...Christopher Baines
2024-03-19services: sddm: Add extension for localed-service-type....Zheng Junjie
2024-02-24services: gdm: Enable wayland by default....Vivien Kraus
2024-01-05services: xorg: ‘dbus-daemon-wrapper’ handles Home profile....Feng Shu
2023-06-04services: screen-locker-service-type: Configurable PAM and setuid....muradm
2023-05-11system: pam: Let PAM extensions add shepherd requirements....Josselin Poiret
2023-03-25services: xorg-wrapper: Support xorg server input rewriting....r0man
2023-03-10services: xorg: Deprecate 'screen-locker-service' procedure....Bruno Victal
2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès
2022-10-11services: slim-service-type: Do not extend profile with xterm....Maxim Cournoyer
2022-10-07services: xorg: Add auto-suspend? field to <gdm-configuration>....Maxim Cournoyer
2022-10-07services: Add dconf-service-type....Maxim Cournoyer
2022-10-07services: gdm: Add a configuration field to enable XDMCP....Maxim Cournoyer
2022-09-16services: desktop: Mount /var/lib/gdm on a tmpfs file system....Maxim Cournoyer