From fc401acb15f15d487c942437b6fb429289dd3c67 Mon Sep 17 00:00:00 2001 From: Julien Lepiller Date: Fri, 31 May 2019 13:22:25 +0200 Subject: [PATCH] Add installation directory as a default directory. In Guix, this library is installed in a separate directory in the store, and it's typically not installed system-wide in a fixed directory. Add the store path to the set of default directories so dependents can find default langs and source highlighting scheme. --- gtksourceview/gtksourceview-utils.c | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/gtksourceview/gtksourceview-utils.c b/gtksourceview/gtksourceview-utils.c index 6f06bab..c3467d5 100644 --- a/gtksourceview/gtksourceview-utils.c +++ b/gtksourceview/gtksourceview-utils.c @@ -66,6 +66,12 @@ _gtk_source_view_get_default_dirs (const char *basename, basename, NULL)); + /* installed dir */ + g_ptr_array_add (dirs, g_build_filename (DATADIR, + SOURCEVIEW_DIR, + basename, + NULL)); + g_ptr_array_add (dirs, NULL); return (gchar**) g_ptr_array_free (dirs, FALSE); -- 2.21.0 logtreecommitdiff
path: root/gnu/packages/cpp.scm
AgeCommit message (Expand)Author
2019-11-21gnu: json-modern-cxx: Update to 3.7.3....* gnu/packages/cpp.scm (json-modern-cxx): Update to 3.7.3. Marius Bakke
2019-11-15gnu: Add cpplint....* gnu/packages/cpp.scm (cpplint): New variable. Mathieu Othacehe
2019-11-03gnu: xtl: Update to 0.6.8....* gnu/packages/cpp.scm (xtl): Update to 0.6.8. Tobias Geerinckx-Rice
2019-10-22gnu: Add gperftools....* gnu/packages/cpp.scm (gperftools): New variable. Pierre Neidhardt
2019-10-12gnu: json-modern-cxx: Update to 3.7.0....* gnu/packages/cpp.scm (json-modern-cxx): Update to 3.7.0. [source](snippet): Adjust for new doctest requirement. [native-inputs]: Add DOCTEST. [inputs]: Remove CATCH-FRAMEWORK2. Marius Bakke
2019-10-01Merge branch 'master' into core-updatesLudovic Courtès
2019-09-28gnu: xtl: Update to 0.6.7....* gnu/packages/cpp.scm (xtl): Update to 0.6.7. Tobias Geerinckx-Rice
2019-09-26gnu: Add ccls....* gnu/packages/cpp.scm (ccls): New variable. Mathieu Othacehe
2019-06-07gnu: dashel: Don't use unstable tarball....* gnu/packages/cpp.scm (dashel)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page]: Move down to its conventional spot. Tobias Geerinckx-Rice
2019-06-07gnu: xsimd: Update to 7.2.3....* gnu/packages/cpp.scm (xsimd): Update to 7.2.3. [arguments]: Add a configure flag required to build the tests. Tobias Geerinckx-Rice
2019-06-07gnu: xsimd: Don't use unstable tarball....* gnu/packages/cpp.scm (xsimd)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page]: Move down to its conventional spot. Tobias Geerinckx-Rice
2019-05-11gnu: xtl: Update to 0.6.4....* gnu/packages/cpp.scm (xtl): Update to 0.6.4. Tobias Geerinckx-Rice
2019-04-19gnu: rct: Be more idiomatic....* gnu/packages/cpp.scm (rct): Move the call to 'git-version' into the package definition. [source]: Explicitly include the source URI rather than using 'home-page'. Leo Famulari