From fc401acb15f15d487c942437b6fb429289dd3c67 Mon Sep 17 00:00:00 2001 From: Julien Lepiller Date: Fri, 31 May 2019 13:22:25 +0200 Subject: [PATCH] Add installation directory as a default directory. In Guix, this library is installed in a separate directory in the store, and it's typically not installed system-wide in a fixed directory. Add the store path to the set of default directories so dependents can find default langs and source highlighting scheme. --- gtksourceview/gtksourceview-utils.c | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/gtksourceview/gtksourceview-utils.c b/gtksourceview/gtksourceview-utils.c index 6f06bab..c3467d5 100644 --- a/gtksourceview/gtksourceview-utils.c +++ b/gtksourceview/gtksourceview-utils.c @@ -66,6 +66,12 @@ _gtk_source_view_get_default_dirs (const char *basename, basename, NULL)); + /* installed dir */ + g_ptr_array_add (dirs, g_build_filename (DATADIR, + SOURCEVIEW_DIR, + basename, + NULL)); + g_ptr_array_add (dirs, NULL); return (gchar**) g_ptr_array_free (dirs, FALSE); -- 2.21.0 ss='active' href='/guix/log/tests/store.scm'>logtreecommitdiff
path: root/tests/store.scm
AgeCommit message (Expand)Author
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès
2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-10-28store: 'map/accumulate-builds' handler checks the store received....Ludovic Courtès
2021-09-17Merge branch 'master' into core-updates-frozen...Marius Bakke
2021-09-15store: 'map/accumulate-builds' processes the whole list in case of cutoff....Ludovic Courtès
2021-07-05tests: Fix typo in 'tests/store.scm'....Ludovic Courtès
2021-06-08store: Remove 'references/substitutes'....Ludovic Courtès
2021-03-18tests: Make the STORE test more robust in a "pure" environment....Leo Famulari
2021-01-22store: Add 'find-roots' RPC....Ludovic Courtès
2020-12-19tests: Make sure substituted items are deduplicated....Ludovic Courtès
2020-12-19tests: Check the mtime and permissions of substituted items....Ludovic Courtès
2020-12-19tests: Check the build trace for hash mismatches on substitutes....Ludovic Courtès