Having DISABLE_DEPRECATED flags set in the distribution breaks
building with libraries later than those which the maintainer
happened to have installed. This patch removes them.
diff -r -U 3 a/gtk/Makefile.am b/gtk/Makefile.am
--- a/gtk/Makefile.am 2003-05-09 15:55:05.000000000 +0200
+++ b/gtk/Makefile.am 2013-12-26 15:06:38.000000000 +0100
@@ -36,11 +36,7 @@
-I$(top_srcdir) \
-I$(top_builddir)/gdk \
$(GTKGLEXT_DEBUG_FLAGS) \
- $(GTKGLEXT_DEP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED
+ $(GTKGLEXT_DEP_CFLAGS)
common_ldflags = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
diff -r -U 3 a/gtk/Makefile.in b/gtk/Makefile.in
--- a/gtk/Makefile.in 2006-02-05 04:17:42.000000000 +0100
+++ b/gtk/Makefile.in 2013-12-26 15:07:00.000000000 +0100
@@ -234,11 +234,7 @@
-I$(top_srcdir) \
-I$(top_builddir)/gdk \
$(GTKGLEXT_DEBUG_FLAGS) \
- $(GTKGLEXT_DEP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED
+ $(GTKGLEXT_DEP_CFLAGS)
common_ldflags = \
class='active' href='/guix/log/gnu/services/version-control.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-01-10 | services: git-daemon: Deprecate 'git-daemon-service' procedure....* gnu/services/version-control.scm
(git-daemon-service): Define with 'define-deprecated'
* doc/guix.texi (Version Control Services): Replace with
'git-daemon-service-type'
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Bruno Victal |
2022-11-17 | services: gitolite: Use the correct variable for the user-group....The default value for <gitolite-configuration> has "git" for both the values
of the user and the group, as costumary, which means that unless someone uses
a custom configuration and chooses different strings for user and group, this
wouldn't show up.
* gnu/services/version-control.scm (gitolite-accounts): Use the correct
variable for the name of a (user-group ...).
Signed-off-by: Christopher Baines <mail@cbaines.net>
| EuAndreh |
2022-11-07 | services: gitolite: Add local-code configuration option....* gnu/services/version-control.scm (gitolite-rc-file): Add local-code
field.
(gitolite-rc-file-compiler): Serialize the field.
* doc/guix.texi: Document it.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| Alexey Abramov |
2022-10-17 | guix: Fix typos....These typos were found and reported through weblate.
* gnu/packages/audio.scm (wildmidi)[description]: Fix typo.
* gnu/packages/games.scm (cgoban)[description]: Fix typo.
* gnu/services/version-control.scm (gitolite-service-type)[description]:
Fix typo.
* gnu/installer/newt/substitutes.scm (run-substitutes-page): Remove full
stop at end of title.
* gnu/machine/ssh.scm (machine-ssh-configuration-system): Move
punctuation outside of quotes.
* guix/scripts/home.scm (process-action): Remove trailing space before
newline.
* guix/scripts/system.scm (show-help): Fix typo.
* guix/scripts/environment.scm (with-store/maybe): Fix typo.
| Julien Lepiller |