Having DISABLE_DEPRECATED flags set in the distribution breaks
building with libraries later than those which the maintainer
happened to have installed. This patch removes them.
diff -r -U 3 a/gtk/Makefile.am b/gtk/Makefile.am
--- a/gtk/Makefile.am 2003-05-09 15:55:05.000000000 +0200
+++ b/gtk/Makefile.am 2013-12-26 15:06:38.000000000 +0100
@@ -36,11 +36,7 @@
-I$(top_srcdir) \
-I$(top_builddir)/gdk \
$(GTKGLEXT_DEBUG_FLAGS) \
- $(GTKGLEXT_DEP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED
+ $(GTKGLEXT_DEP_CFLAGS)
common_ldflags = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
diff -r -U 3 a/gtk/Makefile.in b/gtk/Makefile.in
--- a/gtk/Makefile.in 2006-02-05 04:17:42.000000000 +0100
+++ b/gtk/Makefile.in 2013-12-26 15:07:00.000000000 +0100
@@ -234,11 +234,7 @@
-I$(top_srcdir) \
-I$(top_builddir)/gdk \
$(GTKGLEXT_DEBUG_FLAGS) \
- $(GTKGLEXT_DEP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED
+ $(GTKGLEXT_DEP_CFLAGS)
common_ldflags = \
/gnu/build/svg.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2018-06-01 | bootloader: grub: Use 'with-extensions'....* gnu/bootloader/grub.scm (svg->png): Use 'with-extensions'. Remove
'add-to-load-path' calls.
* gnu/build/svg.scm: Use (rsvg) and (cairo) the normal way. Remove
'module-autoload!' calls.
| Ludovic Courtès |
2017-07-02 | gnu: Switch guile-cairo and dependents to Guile 2.2 again....Fixes <https://bugs.gnu.org/27551>.
Reported by Leo Famulari <leo@famulari.name>.
This reinstates the following commits:
e3ddb1e83 * gnu: guile-cairo: Switch to Guile 2.2.
ae5c6ef39 * gnu: guile-gnome: Update to 2.16.5.
0fd8013fc * gnu: guile-rsvg: Update to commit 05c6a2fd.
66b9183c4 * gnu: guile-lib: Switch to Guile 2.2.
and adds the following changes:
* gnu/bootloader/grub.scm (svg->png): Add 'package->derivation' call for
GUILE-2.2. Pass #:guile-for-build to 'gexp->derivation'.
* gnu/build/svg.scm (svg->png): Add 'em' and 'ex' to the 'let-values'
form to account for all the values returned by
'rsvg-handle-get-dimensions', which Guile 2.2 does not truncate.
| Ludovic Courtès |