This patch makes GTK+ look for additional modules in a list of directories specified by the environment variable "GUIX_GTK3_PATH". This can be used instead of "GTK_PATH" to make GTK+ find modules that are incompatible with other major versions of GTK+. --- a/gtk/gtkmodules.c 2015-09-20 20:09:05.060590217 +0200 +++ b/gtk/gtkmodules.c 2015-09-20 20:10:33.423124833 +0200 @@ -52,6 +52,7 @@ get_module_path (void) { const gchar *module_path_env; + const gchar *module_guix_gtk3_path_env; const gchar *exe_prefix; gchar *module_path; gchar *default_dir; @@ -61,6 +62,7 @@ return result; module_path_env = g_getenv ("GTK_PATH"); + module_guix_gtk3_path_env = g_getenv ("GUIX_GTK3_PATH"); exe_prefix = g_getenv ("GTK_EXE_PREFIX"); if (exe_prefix) @@ -68,7 +70,13 @@ else default_dir = g_build_filename (_gtk_get_libdir (), "gtk-3.0", NULL); - if (module_path_env) + if (module_guix_gtk3_path_env && module_path_env) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk3_path_env, module_path_env, default_dir, NULL); + else if (module_guix_gtk3_path_env) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk3_path_env, default_dir, NULL); + else if (module_path_env) module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, module_path_env, default_dir, NULL); else commitdiff
path: root/gnu/tests/web.scm
AgeCommit message (Expand)Author
2023-01-22gnu: hpcguix-web: Update to 0.3.0....Ludovic Courtès
2022-05-01tests: Fix tailon test....Mathieu Othacehe
2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe
2021-12-06tests: patchwork: Use the default PostgreSQL....Marius Bakke
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-15gnu: hpcguix-web: Update to 0.2.0....Ludovic Courtès
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-06-01tests: hpcguix-web: Fix it....Mathieu Othacehe