This patch makes GTK+ look for additional modules in a list of directories
specified by the environment variable "GUIX_GTK3_PATH". This can be used
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
other major versions of GTK+.
--- a/gtk/gtkmodules.c 2015-09-20 20:09:05.060590217 +0200
+++ b/gtk/gtkmodules.c 2015-09-20 20:10:33.423124833 +0200
@@ -52,6 +52,7 @@
get_module_path (void)
{
const gchar *module_path_env;
+ const gchar *module_guix_gtk3_path_env;
const gchar *exe_prefix;
gchar *module_path;
gchar *default_dir;
@@ -61,6 +62,7 @@
return result;
module_path_env = g_getenv ("GTK_PATH");
+ module_guix_gtk3_path_env = g_getenv ("GUIX_GTK3_PATH");
exe_prefix = g_getenv ("GTK_EXE_PREFIX");
if (exe_prefix)
@@ -68,7 +70,13 @@
else
default_dir = g_build_filename (_gtk_get_libdir (), "gtk-3.0", NULL);
- if (module_path_env)
+ if (module_guix_gtk3_path_env && module_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk3_path_env, module_path_env, default_dir, NULL);
+ else if (module_guix_gtk3_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk3_path_env, default_dir, NULL);
+ else if (module_path_env)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, default_dir, NULL);
else
637e27be2e050bca7930e660edb4'>commitdiff
|
Age | Commit message (Expand) | Author |
2023-09-17 | gnu: ocl-icd: Delete dubiously deprecated duplicate definition....This follows up on commit 3341b22f594398b3aa3ff930d99b74a78abd1a30 which
re-added ocl-icd. opencl-icd-loader is a different, incompatible package.
* gnu/packages/opencl.scm (ocl-icd): Remove duplicate variable.
| Tobias Geerinckx-Rice |
2023-09-10 | Revert "gnu: beignet: Fix build."...This reverts commit 213516f0baf92b6f50bd0c2e005625c0b3421a6f,
which removed ICD support entirely.
| Tobias Geerinckx-Rice |
2023-09-10 | gnu: beignet: Fix build....* gnu/packages/opencl.scm (beignet)[inputs]: Add ocl-icd.
| Tobias Geerinckx-Rice |
2023-09-10 | gnu: Add ocl-icd....* gnu/packages/opencl.scm (ocl-icd): New public variable.
| Tobias Geerinckx-Rice |
2023-09-15 | gnu: beignet: Fix build....* gnu/packages/opencl.scm (beignet)[arguments]: Add configure flag.
| Andreas Enge |