From: Jookia <166291@gmail.com>
Subject: [PATCHv2] gtk: Patch GTK+ to look for themes in profiles.
To: guix-devel@gnu.org
Date: Sun, 13 Mar 2016 15:17:37 +1100
Url: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00492.html
diff -Naur gtk+-2.24.28.new/gtk/gtkrc.c gtk+-2.24.28/gtk/gtkrc.c
--- gtk+-2.24.28.new/gtk/gtkrc.c 2016-03-13 10:31:14.413644362 +1100
+++ gtk+-2.24.28/gtk/gtkrc.c 2016-03-13 12:51:34.723398423 +1100
@@ -808,6 +808,8 @@
gchar *path = NULL;
const gchar *home_dir;
gchar *subpath;
+ const gchar * const *xdg_data_dirs;
+ gint i;
if (type)
subpath = g_strconcat ("gtk-2.0-", type,
@@ -830,6 +832,22 @@
}
if (!path)
+ {
+ xdg_data_dirs = g_get_system_data_dirs ();
+ for (i = 0; xdg_data_dirs[i]; i++)
+ {
+ path = g_build_filename (xdg_data_dirs[i], "themes", name, subpath, NULL);
+ if (g_file_test (path, G_FILE_TEST_EXISTS))
+ break;
+ else
+ {
+ g_free (path);
+ path = NULL;
+ }
+ }
+ }
+
+ if (!path)
{
gchar *theme_dir = gtk_rc_get_theme_dir ();
path = g_build_filename (theme_dir, name, subpath, NULL);
og/gnu/packages/potassco.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-07-08 | gnu: emacs-pasp-mode: Use a source file-name....* gnu/packages/potassco.scm (emacs-pasp-mode)[source]: Use a source
file-name.
| Efraim Flashner |
2023-07-01 | gnu: catch2: Update to 3.3.2....* gnu/packages/check.scm (catch2-3.1): Rename to catch2-3.3.
[version, source]: Update to 3.3.2.
[outputs]: Remove ‘doc’.
[build-system]: Use cmake-build-system.
[arguments]: Remove special phases. Add CMake options to #:configure-flags.
* gnu/packages/potassco.scm (clingo): Adjust accordingly.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| David Elsing |
2023-07-01 | gnu: clingo: Unbundle dependencies....* gnu/packages/potassco.scm: (clingo)[#:phases]: Patch CMakeLists.txt files to
use external dependencies.
[native-inputs]: Add mpark-variant, tl-optional, tsl-hopscotch-map,
tsl-ordered-map and tsl-sparse-map.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| David Elsing |
2023-05-09 | gnu: Add python-clinguin....* gnu/packages/potassco.scm (python-clinguin): New variable.
| Liliana Marie Prikler |
2023-04-29 | gnu: libpotassco: Unbundle catch....This patch incidentally fixes a build failure caused by the bundled catch.
* gnu/packages/potassco.scm (libpotassco)[source]: Unbundle catch.
[native-inputs]: Add catch2-1.
| Liliana Marie Prikler |
2023-04-19 | gnu: python-typing-extensions: Move to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-typing-extensions): Move to...
* gnu/packages/python-build.scm (python-typing-extensions): ... here.
| Maxim Cournoyer |
2023-04-02 | gnu: Add python-clingraph....* gnu/packages/potassco.scm (python-clingraph): New variable.
| Liliana Marie Prikler |
2023-04-02 | gnu: Separate potassco packages into their own module....* gnu/packages/potassco.scm: New file.
* gnu/packages/maths.scm (libpotassco, clasp, clingo, python-clingo)
(python-telingo): Move to potassco module. Adjust imports accordingly.
* gnu/packages/emacs-xyz.scm (emacs-pasp-mode): Move to potassco module.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add %D%/packages/potassco.scm.
| Liliana Marie Prikler |