From: Jookia <166291@gmail.com> Subject: [PATCHv2] gtk: Patch GTK+ to look for themes in profiles. To: guix-devel@gnu.org Date: Sun, 13 Mar 2016 15:17:37 +1100 Url: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00492.html diff -Naur gtk+-2.24.28.new/gtk/gtkrc.c gtk+-2.24.28/gtk/gtkrc.c --- gtk+-2.24.28.new/gtk/gtkrc.c 2016-03-13 10:31:14.413644362 +1100 +++ gtk+-2.24.28/gtk/gtkrc.c 2016-03-13 12:51:34.723398423 +1100 @@ -808,6 +808,8 @@ gchar *path = NULL; const gchar *home_dir; gchar *subpath; + const gchar * const *xdg_data_dirs; + gint i; if (type) subpath = g_strconcat ("gtk-2.0-", type, @@ -830,6 +832,22 @@ } if (!path) + { + xdg_data_dirs = g_get_system_data_dirs (); + for (i = 0; xdg_data_dirs[i]; i++) + { + path = g_build_filename (xdg_data_dirs[i], "themes", name, subpath, NULL); + if (g_file_test (path, G_FILE_TEST_EXISTS)) + break; + else + { + g_free (path); + path = NULL; + } + } + } + + if (!path) { gchar *theme_dir = gtk_rc_get_theme_dir (); path = g_build_filename (theme_dir, name, subpath, NULL); /services/linux.scm'>logtreecommitdiff
path: root/gnu/services/linux.scm
AgeCommit message (Expand)Author
2023-10-07services: fstrim-service-type: Serialize with SRFI-171 transducers....Bruno Victal
2023-08-21gnu: earlyoom: Improve description....Ludovic Courtès
2023-08-21services: earlyoom: Move 'user-processes' to 'requirements'....Ludovic Courtès
2023-08-21services: Add missing 'user-processes' requirements....Ludovic Courtès
2023-08-15services: Add cachefilesd service....Felix Lechner
2023-05-04services: earlyoom: Rotate log files....Efraim Flashner
2023-04-02services: replace bare serializers with (serializer ...)...Bruno Victal
2023-03-28services: fstrim: Fix schedule ungexp....Bruno Victal
2023-03-22services: Add fstrim-service-type....Bruno Victal
2022-06-11system: Align zram priority with swap-space spec to clarify....Josselin Poiret