From: Jookia <166291@gmail.com> Subject: [PATCHv2] gtk: Patch GTK+ to look for themes in profiles. To: guix-devel@gnu.org Date: Sun, 13 Mar 2016 15:17:37 +1100 Url: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00492.html diff -Naur gtk+-2.24.28.new/gtk/gtkrc.c gtk+-2.24.28/gtk/gtkrc.c --- gtk+-2.24.28.new/gtk/gtkrc.c 2016-03-13 10:31:14.413644362 +1100 +++ gtk+-2.24.28/gtk/gtkrc.c 2016-03-13 12:51:34.723398423 +1100 @@ -808,6 +808,8 @@ gchar *path = NULL; const gchar *home_dir; gchar *subpath; + const gchar * const *xdg_data_dirs; + gint i; if (type) subpath = g_strconcat ("gtk-2.0-", type, @@ -830,6 +832,22 @@ } if (!path) + { + xdg_data_dirs = g_get_system_data_dirs (); + for (i = 0; xdg_data_dirs[i]; i++) + { + path = g_build_filename (xdg_data_dirs[i], "themes", name, subpath, NULL); + if (g_file_test (path, G_FILE_TEST_EXISTS)) + break; + else + { + g_free (path); + path = NULL; + } + } + } + + if (!path) { gchar *theme_dir = gtk_rc_get_theme_dir (); path = g_build_filename (theme_dir, name, subpath, NULL); active' href='/guix/log/.patman?showmsg=1'>logtreecommitdiff
path: root/.patman
AgeCommit message (Collapse)Author
2023-10-22gnu: patman: Apply patch for new Change-Id setting.Maxim Cournoyer
* gnu/packages/bootloaders.scm (u-boot) [source]: Apply patch. * gnu/packages/patches/u-boot-patman-change-id.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * .patman (keep_change_id): Use it. Series-changes: 3 - New commit Change-Id: I33c03013f6a260b5f5d80212b7b6ebe8a3f97efa
2023-05-01.patman: Remove get_maintainer_script option.Maxim Cournoyer
This is now handled at the level of git via its new '--header-cmd' option, which produces X-Debbugs-CC headers. * .patman (get_maintainer_script): Delete option.
2023-02-25.patman: Ignore bad tags.Maxim Cournoyer
The feature is not used in Guix, and it produces extraneous warnings. * .patman (ignore_bad_tags): Set option to True.
2022-12-28.patman: New configuration file.Maxim Cournoyer
* .patman: New file. Series-to: 60218@debbugs.gnu.org Series-cc: rekado@elephly.net, othacehe@gnu.org Series-version: 2