This patch makes GTK+ look for additional modules in a list of directories specified by the environment variable "GUIX_GTK2_PATH". This can be used instead of "GTK_PATH" to make GTK+ find modules that are incompatible with other major versions of GTK+. --- a/gtk/gtkmodules.c 2014-09-29 22:02:17.000000000 +0200 +++ b/gtk/gtkmodules.c 2015-12-02 18:41:53.306396938 +0100 @@ -55,6 +55,7 @@ get_module_path (void) { const gchar *module_path_env; + const gchar *module_guix_gtk2_path_env; const gchar *exe_prefix; const gchar *home_dir; gchar *home_gtk_dir = NULL; @@ -70,6 +71,7 @@ home_gtk_dir = g_build_filename (home_dir, ".gtk-2.0", NULL); module_path_env = g_getenv ("GTK_PATH"); + module_guix_gtk2_path_env = g_getenv ("GUIX_GTK2_PATH"); exe_prefix = g_getenv ("GTK_EXE_PREFIX"); if (exe_prefix) @@ -77,9 +79,21 @@ else default_dir = g_build_filename (GTK_LIBDIR, "gtk-2.0", NULL); - if (module_path_env && home_gtk_dir) + if (module_guix_gtk2_path_env && module_path_env && home_gtk_dir) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk2_path_env, module_path_env, home_gtk_dir, default_dir, NULL); + else if (module_guix_gtk2_path_env && home_gtk_dir) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk2_path_env, home_gtk_dir, default_dir, NULL); + else if (module_guix_gtk2_path_env && module_path_env) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk2_path_env, module_path_env, default_dir, NULL); + else if (module_path_env && home_gtk_dir) module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, module_path_env, home_gtk_dir, default_dir, NULL); + else if (module_guix_gtk2_path_env) + module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, + module_guix_gtk2_path_env, default_dir, NULL); else if (module_path_env) module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S, module_path_env, default_dir, NULL); id=028959236dee5e2f851218ea6418675531b400cd'>root/tests/opam.scm
AgeCommit message (Expand)Author
2024-04-15utils: Don’t re-export ‘call-with-temporary-output-file’....Ludovic Courtès
2023-05-31tests: Use quasiquoted 'match' patterns for package sexps....Ludovic Courtès
2021-11-18tests: Adjust opam and pypi tests to simplified inputs....Ludovic Courtès
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-09-18tests: Allow opam test to run without networking....Ludovic Courtès
2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-08-21guix: opam: More flexibility in the importer....Alice BRENON
2021-07-20import: opam: Emit new-style package inputs....Sarah Morgensen
2021-05-28import: opam: Generate license for package....Xinglu Chen
2020-12-08import: opam: Adjust test to latest 'opam->guix-package' changes....Ludovic Courtès
2020-12-08guix: opam: Pass default repository to recursive importer....Julien Lepiller
2020-10-02tests: opam: Test additional syntax....Julien Lepiller
2020-10-02tests: opam: Factorize tests....Julien Lepiller
2020-01-17import: opam: Avoid uses of '@@' in tests....Ludovic Courtès
2019-09-07tests: opam: Fix input type in import test....Julien Lepiller
2019-02-05import: opam: Fix conditions....Julien Lepiller
2018-12-17import: Update opam importer....Julien Lepiller
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-07-10guix: Add opam importer....Julien Lepiller