This patch makes GTK+ look for additional modules in a list of directories
specified by the environment variable "GUIX_GTK2_PATH". This can be used
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
other major versions of GTK+.
--- a/gtk/gtkmodules.c 2014-09-29 22:02:17.000000000 +0200
+++ b/gtk/gtkmodules.c 2015-12-02 18:41:53.306396938 +0100
@@ -55,6 +55,7 @@
get_module_path (void)
{
const gchar *module_path_env;
+ const gchar *module_guix_gtk2_path_env;
const gchar *exe_prefix;
const gchar *home_dir;
gchar *home_gtk_dir = NULL;
@@ -70,6 +71,7 @@
home_gtk_dir = g_build_filename (home_dir, ".gtk-2.0", NULL);
module_path_env = g_getenv ("GTK_PATH");
+ module_guix_gtk2_path_env = g_getenv ("GUIX_GTK2_PATH");
exe_prefix = g_getenv ("GTK_EXE_PREFIX");
if (exe_prefix)
@@ -77,9 +79,21 @@
else
default_dir = g_build_filename (GTK_LIBDIR, "gtk-2.0", NULL);
- if (module_path_env && home_gtk_dir)
+ if (module_guix_gtk2_path_env && module_path_env && home_gtk_dir)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, module_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env && home_gtk_dir)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env && module_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, module_path_env, default_dir, NULL);
+ else if (module_path_env && home_gtk_dir)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, default_dir, NULL);
else if (module_path_env)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, default_dir, NULL);
iv class='path'>path: root/gnu/packages/nfs.scm
Age | Commit message (Expand) | Author |
)Author |
2024-08-31 | gnu: policycoreutils: Add libxcrypt dependency....* gnu/packages/selinux.scm (policycoreutils)[inputs]: Add libxcrypt.
Change-Id: I0327a8c3e98c7a39a79bfcdc347a1ea2219477bb
| 宋文武 |
2024-08-31 | gnu: python-sepolgen: Import the correct set of modules....* gnu/packages/selinux.scm (python-sepolgen) [arguments]
<modules>: Replace %default-gnu-imported-modules with %default-gnu-modules.
Change-Id: I1383ff8bb77d07fa4ee05f8d670af00458ec78cb
| Maxim Cournoyer |
2024-08-31 | build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private
%default-modules variable of (guix build-systems gnu) to discover which
modules to include when extending the used modules via the #:modules argument.
The renaming was automated via the command:
$ git grep -l %gnu-build-system-modules
| xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i
* guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to...
(%default-gnu-imported-modules): ... this.
(%default-modules): Rename to...
(%default-gnu-modules): ... this. Export.
(dist-package, gnu-build, gnu-cross-build): Adjust accordingly.
Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee
| Maxim Cournoyer |
2024-08-31 | gnu: secilc: Drop xmlto workaround....The xmlto error[1] was due to libsepol using an unversioned PUBLIC identifier
for DocBook 4.2.
[1]: <https://pagure.io/xmlto/blob/6fa6a0e07644f20abf2596f78a60112713e11cbe/f/FAQ>
* gnu/packages/patches/libsepol-versioned-docbook.patch: New file.
* gnu/local.mk: Register it.
* gnu/packages/selinux.scm (libsepol)[source]: Apply it.
(secilc)[arguments]: Drop xmlto workaround.
[native-inputs]: Add docbook-xml-4.2.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I152dd7a30b2a310ed6589133bc98f5eef8a190a1
| Bruno Victal |