This patch makes GTK+ look for additional modules in a list of directories
specified by the environment variable "GUIX_GTK2_PATH". This can be used
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
other major versions of GTK+.
--- a/gtk/gtkmodules.c 2014-09-29 22:02:17.000000000 +0200
+++ b/gtk/gtkmodules.c 2015-12-02 18:41:53.306396938 +0100
@@ -55,6 +55,7 @@
get_module_path (void)
{
const gchar *module_path_env;
+ const gchar *module_guix_gtk2_path_env;
const gchar *exe_prefix;
const gchar *home_dir;
gchar *home_gtk_dir = NULL;
@@ -70,6 +71,7 @@
home_gtk_dir = g_build_filename (home_dir, ".gtk-2.0", NULL);
module_path_env = g_getenv ("GTK_PATH");
+ module_guix_gtk2_path_env = g_getenv ("GUIX_GTK2_PATH");
exe_prefix = g_getenv ("GTK_EXE_PREFIX");
if (exe_prefix)
@@ -77,9 +79,21 @@
else
default_dir = g_build_filename (GTK_LIBDIR, "gtk-2.0", NULL);
- if (module_path_env && home_gtk_dir)
+ if (module_guix_gtk2_path_env && module_path_env && home_gtk_dir)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, module_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env && home_gtk_dir)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env && module_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, module_path_env, default_dir, NULL);
+ else if (module_path_env && home_gtk_dir)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, home_gtk_dir, default_dir, NULL);
+ else if (module_guix_gtk2_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk2_path_env, default_dir, NULL);
else if (module_path_env)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, default_dir, NULL);
iv class='path'>path: root/gnu/packages/tls.scm
Age | Commit message (Expand) | Author |
2023-09-28 | gnu: openssl@1.1: Upgrade replacement to 1.1.1u....Includes fixes for CVE-2023-0215, CVE-2023-0286, CVE-2023-0464, CVE-2023-0465,
CVE-2023-0466, CVE-2023-2650, CVE-2022-4304, CVE-2022-4450.
* gnu/packages/tls.scm (openssl/fixed): Update to 1.1.1u.
Co-authored-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
| Ludovic Courtès |
2023-09-28 | gnu: openssl@1.1: Really replace with fixed version....The ‘replacement’ field of ‘openssl-1.1’ was apparently lost in a
previous merge commit ca. Jan. 2023; consequently, ‘openssl/fixed’ was
unused.
* gnu/packages/tls.scm (openssl-1.1)[replacement]: New field.
| Ludovic Courtès |
2023-08-13 | gnu: libressl: Update to 3.7.3 [fixes CVE-2023-35784]....Thanks to Dennis 'GNUtoo' Carikli for <https://issues.guix.gnu.org/64982>,
but upgrading to 3.8.0 breaks (at least) OpenSMTPd.
* gnu/packages/tls.scm (libressl): Update to 3.7.3.
| Tobias Geerinckx-Rice |
2023-07-20 | gnu: openssl-1.1: Fix shared build for the Hurd....* gnu/packages/tls.scm (openssl-1.1)[arguments]: When building for the Hurd,
add phase 'patch-configure'.
(openssl)[arguments]: And delete it again.
| Janneke Nieuwenhuizen |
2023-07-20 | gnu: openssl: Build fix for the Hurd....* gnu/packages/tls.scm (openssl-3.0)[arguments]: When building on the Hurd,
add "hurd-x86" to #:configure-flags.
| Janneke Nieuwenhuizen |