This patch replaces the environment variable "GTK_IM_MODULE" with
"GUIX_GTK2_IM_MODULE_FILE" to prevent this version of GTK+ from loading input
method modules for other major versions of GTK+.
--- gtk+-2.24.30/gtk/gtkrc.c 2016-08-21 22:40:22.339660438 +0200
+++ gtk+-2.24.30/gtk/gtkrc.c 2016-08-23 10:11:11.080822710 +0200
@@ -439,7 +439,7 @@
gchar *
gtk_rc_get_im_module_file (void)
{
- const gchar *var = g_getenv ("GTK_IM_MODULE_FILE");
+ const gchar *var = g_getenv ("GUIX_GTK2_IM_MODULE_FILE");
gchar *result = NULL;
if (var)
>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-10-07 | services: Fix gdm-autologin pam service....* gnu/services/xorg.scm (gdm-pam-service): Mark pam_gdm.so optional.
| Alex Griffin |
2020-06-04 | xorg: honor xorg-configuration-server in xorg-configuration->file...Fixes <https://bugs.gnu.org/40806>.
Previously the xorg-server package specified in the configuration was ignored
entirely in xorg-configuration->file. This had the effect that while the X
program of the configured package would be executed, the modules of the
configured package would be ignored in favor of the default xorg-server
package's modules. This fixes that.
* gnu/services/xorg.scm (xorg-configuration->file): honor
xorg-configuration-server.
| Caleb Ristvedt |