Fix a stack corruption when handling files with more than 64 audio channels: https://gstreamer.freedesktop.org/security/sa-2021-0005.html Patch copied from upstream source repository: https://gitlab.freedesktop.org/gstreamer/gst-libav/-/commit/dcea8baa14a5fc3b796d876baaf2f238546ba2b1 diff --git a/ext/libav/gstavcodecmap.c b/ext/libav/gstavcodecmap.c index b5be4bb7a5f2712f78383da9319754a8849e3307..be22f22cf5c7c7b22b13e44b10999adaacbcca2b 100644 --- a/ext/libav/gstavcodecmap.c +++ b/ext/libav/gstavcodecmap.c @@ -102,7 +102,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels, guint nchannels = 0; gboolean none_layout = FALSE; - if (channel_layout == 0) { + if (channel_layout == 0 || channels > 64) { nchannels = channels; none_layout = TRUE; } else { @@ -163,7 +163,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels, } else { guint i; - for (i = 0; i < nchannels; i++) + for (i = 0; i < nchannels && i < 64; i++) pos[i] = GST_AUDIO_CHANNEL_POSITION_NONE; } } href='/guix/refs/?id=7bd5394bf8564920a4e647563dc8c0092858f8dd'>refslogtreecommitdiff
path: root/etc/git
AgeCommit message (Collapse)Author
2021-10-14Add git configuration templates to improve diff hunk header detection.Sarah Morgensen
This is a follow-up to commit 9fc8ae4171e5da4939a64fc6d684c8b9d85bbe84, which missed two hunks from <https://issues.guix.gnu.org/50363>. Reported by hackeryarn on #guix. * .gitattributes, etc/git/gitconfig: New files. Signed-off-by: Marius Bakke <marius@gnu.org>
2020-12-14maint: Only run `make authenticate` when pushing commits.Leo Famulari
* etc/git/pre-push: Exit early when deleting a branch.
2020-06-01maint: Adjust comment in 'pre-push' hook.Ludovic Courtès
* etc/git/pre-push: Adjust comment.
2020-05-29maint: Git pre-push hook runs "make authenticate check-channel-news".Ludovic Courtès
* etc/git/pre-push: Change to run "make authenticate check-channel-news".