Work around a test failure due to a rounding issue on 32-bit
platforms, as reported at:
https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
--- gsl-2.2.1/linalg/test.c 2016-10-05 13:27:42.464059730 +0200
+++ gsl-2.2.1/linalg/test.c 2016-10-05 13:27:46.988095882 +0200
@@ -4843,9 +4843,6 @@ main(void)
gsl_test(test_cholesky_decomp_unit(), "Cholesky Decomposition [unit triangular]");
gsl_test(test_cholesky_solve(), "Cholesky Solve");
- gsl_test(test_cholesky_decomp(r), "Cholesky Decomposition");
- gsl_test(test_cholesky_invert(r), "Cholesky Inverse");
- gsl_test(test_pcholesky_decomp(r), "Pivoted Cholesky Decomposition");
gsl_test(test_pcholesky_solve(r), "Pivoted Cholesky Solve");
gsl_test(test_pcholesky_invert(r), "Pivoted Cholesky Inverse");
gsl_test(test_mcholesky_decomp(r), "Modified Cholesky Decomposition");
value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-07-18 | guix: channels: Enable specifiying available builtin builders....When computing channel instance derivations.
This is useful when you want to generate compatible derivations that can be
run with a daemon that potentially doesn't support builtin builders that the
daemon you're using to generate the derivations has.
I'm looking at this in particular because I want to use this in the data
service, since it provides substitutes for derivations, and since these can be
built on other machines, it's useful to control which builtin builders they
depend on.
Fixes: <https://issues.guix.gnu.org/67250>.
* build-aux/build-self.scm (build-program): Accept
#:built-in-builders and pass along to port->connection or
open-connection as approriate.
(build): Accept and pass on #:built-in-builders.
* guix/channels.scm (build-from-source, build-channel-instance,
channel-instance-derivations, channel-instances->manifest,
channel-instances->derivation): Accept and pass on
#:built-in-builders.
Change-Id: I315c990de66c6f7dca25a859165a5568abe385ea
| Christopher Baines |