Work around a test failure due to a rounding issue on 32-bit
platforms, as reported at:
https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
--- gsl-2.2.1/linalg/test.c 2016-10-05 13:27:42.464059730 +0200
+++ gsl-2.2.1/linalg/test.c 2016-10-05 13:27:46.988095882 +0200
@@ -4843,9 +4843,6 @@ main(void)
gsl_test(test_cholesky_decomp_unit(), "Cholesky Decomposition [unit triangular]");
gsl_test(test_cholesky_solve(), "Cholesky Solve");
- gsl_test(test_cholesky_decomp(r), "Cholesky Decomposition");
- gsl_test(test_cholesky_invert(r), "Cholesky Inverse");
- gsl_test(test_pcholesky_decomp(r), "Pivoted Cholesky Decomposition");
gsl_test(test_pcholesky_solve(r), "Pivoted Cholesky Solve");
gsl_test(test_pcholesky_invert(r), "Pivoted Cholesky Inverse");
gsl_test(test_mcholesky_decomp(r), "Modified Cholesky Decomposition");
witch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-06-05 | git-authenticate: Add tests....* guix/tests/git.scm (call-with-environment-variables)
(with-environment-variables): Remove.
* guix/tests/git.scm (populate-git-repository): Add clauses for signed
commits and signed merges.
* guix/tests/gnupg.scm: New file.
* tests/git-authenticate.scm: New file.
* tests/ed25519bis.key, tests/ed25519bis.sec: New files.
* Makefile.am (dist_noinst_DATA): Add 'guix/tests/gnupg.scm'.
(SCM_TESTS): Add 'tests/git-authenticate.scm'.
(EXTRA_DIST): Add tests/ed25519bis.{key,sec}.
| Ludovic Courtès |