Fix type comparison issue that is a hard error in GCC 10.
Taken from upstream:
https://github.com/OpenTTD/grfcodec/commit/bb692b2c723c5e87cc8f89f445928e97594d5b8f
diff --git a/src/command.cpp b/src/command.cpp
index 9aa0e14..1f32cf1 100644
--- a/src/command.cpp
+++ b/src/command.cpp
@@ -300,8 +300,9 @@ bool parse_comment(const string&line){
break;
case BEAUTIFY:{
commandstream>>command_part;
- uint val=find_command(command_part,beaut),togglebit;
- if(val!=(uint)-1&&val!=OFF)_commandState.beautifier=true;
+ int val=find_command(command_part,beaut);
+ uint togglebit;
+ if(val!=-1&&val!=OFF)_commandState.beautifier=true;
switch(val){
case -1:
IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
@@ -372,7 +373,7 @@ bool parse_comment(const string&line){
dotoggle:
commandstream>>command_part;
val=find_command(command_part,beaut);
- if(!commandstream||val==(uint)-1){
+ if(!commandstream||val==-1){
IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
return true;
}
d>
aboutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2017-03-12 | services: Move configuration functions that shouldn't be factorized....* gnu/services/configuration.scm (serialize-field, serialize-string)
(serialize-space-separated-string-list, space-separated-string-list?)
(serialize-file-name, file-name?, serialize-boolean): Move these functions...
* gnu/services/cups.scm: ...to this file.
* gnu/services/kerberos.scm: ...to this file.
Configuration syntaxes are very specific to services. Some services may have
the same configuration syntax, but none of them is common enough to be
abstracted in configuration.scm.
Signed-off-by: Clément Lassieur <clement@lassieur.org>
| Clément Lassieur |
2016-12-03 | gnu: Add Kerberos client service....* doc/guix.texi (Kerberos Services)[Krb5 Service]: New subsubheading.
* gnu/services/kerberos.scm (krb5-service-type): New variable.
* gnu/services/configuration.scm (configuration-field-serializer,
configuration-field-getter): Export variables.
| John Darrington |
2016-11-26 | gnu: Whitespace changes...* gnu/services/kerberos.scm: Fold lines to 80 character limit.
| John Darrington |
2016-11-08 | gnu: Add pam-krb5 service....* doc/guix.texi (Kerberos Services): New node.
* gnu/services/kerberos.scm: New file.
* gnu/local.mk: Add it.
| John Darrington |