Fix type comparison issue that is a hard error in GCC 10.
Taken from upstream:
https://github.com/OpenTTD/grfcodec/commit/bb692b2c723c5e87cc8f89f445928e97594d5b8f
diff --git a/src/command.cpp b/src/command.cpp
index 9aa0e14..1f32cf1 100644
--- a/src/command.cpp
+++ b/src/command.cpp
@@ -300,8 +300,9 @@ bool parse_comment(const string&line){
break;
case BEAUTIFY:{
commandstream>>command_part;
- uint val=find_command(command_part,beaut),togglebit;
- if(val!=(uint)-1&&val!=OFF)_commandState.beautifier=true;
+ int val=find_command(command_part,beaut);
+ uint togglebit;
+ if(val!=-1&&val!=OFF)_commandState.beautifier=true;
switch(val){
case -1:
IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
@@ -372,7 +373,7 @@ bool parse_comment(const string&line){
dotoggle:
commandstream>>command_part;
val=find_command(command_part,beaut);
- if(!commandstream||val==(uint)-1){
+ if(!commandstream||val==-1){
IssueMessage(0,COMMAND_INVALID_ARG,gen[BEAUTIFY].name);
return true;
}
a href='/guix/about/'>aboutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-06-26 | etc: Add explicit ‘--substitute-urls’ in guix-daemon service files....Having substitute URLs explicitly listed in the service startup file
makes it clearer what should be modified to permanently change the list
of substitute URLs.
* config-daemon.ac: Rename ‘guix_substitute_urls’ to
‘GUIX_SUBSTITUTE_URLS’ and substitute it.
* nix/local.mk (etc/guix-%.service, etc/init.d/guix-daemon)
(etc/guix-%.conf): Substitute it.
* etc/guix-daemon.conf.in, etc/guix-daemon.service.in,
etc/init.d/guix-daemon.in: Add an explicit ‘--substitute-urls’ option.
Change-Id: Ie491b7fab5c42e54dca582801c03805a85de2bf9
| Ludovic Courtès |