Fix building of GPM with glibc 2.26: https://bugs.gentoo.org/629774 Patches copied from Gentoo: https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-glibc-2.26.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649 https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649 --- a/src/prog/gpm-root.y 2012-10-26 17:21:38.000000000 -0400 +++ b/src/prog/gpm-root.y 2017-09-07 20:39:51.933264063 -0400 @@ -1197,7 +1197,7 @@ /* reap your zombies */ childaction.sa_handler=reap_children; #if defined(__GLIBC__) - __sigemptyset(&childaction.sa_mask); + sigemptyset(&childaction.sa_mask); #else /* __GLIBC__ */ childaction.sa_mask=0; #endif /* __GLIBC__ */ From b350aee4ea5785a75cb6ad770f6b768c506ebb70 Mon Sep 17 00:00:00 2001 From: Mike Frysinger Date: Mon, 14 Mar 2016 15:39:54 -0400 Subject: [PATCH] fix building w/newer glibc Linux C libraries are looking to disentangle sysmacros.h from the sys/types.h include, so make sure we pull in the header when it is found. --- src/daemon/open_console.c | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c index 4d6c0af..6dd43e6 100644 --- a/src/daemon/open_console.c +++ b/src/daemon/open_console.c @@ -24,6 +24,10 @@ #include /* major() */ #include /* ioctl */ +#ifdef HAVE_SYS_SYSMACROS_H +#include /* major() w/newer glibc */ +#endif + /* Linux specific (to be outsourced in gpm2 */ #include /* for serial console check */ #include /* for serial console check */ -- 2.6.2 or'>author
AgeCommit message (Expand)Author
2020-11-29gnu: Add ocrodjvu....* gnu/packages/djvu.scm (ocrodjvu): New variable. Guillaume Le Vaillant
2020-11-29gnu: Add didjvu....* gnu/packages/djvu.scm (didjvu): New variable. Guillaume Le Vaillant
2020-11-26gnu: djvulibre: Remove bundled software....* gnu/packages/djvu.scm (djvulibre)[source]: Delete win32/ in a snippet. Tobias Geerinckx-Rice
2020-11-26gnu: djvulibre: Update to 3.5.28....* gnu/packages/djvu.scm (djvulibre): Update to 3.5.28. [native-inputs]: Add autoconf, automake, and libtool to bootstrap. [inputs]: Add zlib. [arguments]: Rename 'reproducible phase to 'make-reproducible and run it after bootstrapping. Tobias Geerinckx-Rice
2020-11-26gnu: djvusmooth: Fix path to djvused....* gnu/packages/djvu.scm (djvusmooth)[arguments]: Add 'fix-paths' phase. Guillaume Le Vaillant
2020-11-23gnu: djview: Update to 4.12....* gnu/packages/djvu.scm (djview): Update to 4.12. Tobias Geerinckx-Rice
2020-11-23gnu: Add djvusmooth....* gnu/packages/djvu.scm (djvusmooth): New variable. Guillaume Le Vaillant
2020-11-22gnu: Add minidjvu....* gnu/packages/djvu.scm (minidjvu): New variable. Guillaume Le Vaillant
2020-11-22gnu: djvulibre: Add JPEG and TIFF support....* gnu/packages/djvu.scm (djvulibre)[inputs]: Add libjpeg-turbo and libtiff. Guillaume Le Vaillant
2020-11-22gnu: Add djvu2pdf....* gnu/packages/djvu.scm (djvu2pdf): New variable. Guillaume Le Vaillant
2020-11-16gnu: Add pdf2djvu....* gnu/packages/djvu.scm (pdf2djvu): New variable. Guillaume Le Vaillant
2020-06-10gnu: djview: Update to 4.11....* gnu/packages/djvu.scm (djview): Update to 4.11. [source]: Use GIT-FETCH and add a FILE-NAME. [native-inputs]: Add autoconf, automake, and libtool. [arguments]: Add a ‘make-files-writable’ phase. Tobias Geerinckx-Rice