Fix building of GPM with glibc 2.26: https://bugs.gentoo.org/629774 Patches copied from Gentoo: https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-glibc-2.26.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649 https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649 --- a/src/prog/gpm-root.y 2012-10-26 17:21:38.000000000 -0400 +++ b/src/prog/gpm-root.y 2017-09-07 20:39:51.933264063 -0400 @@ -1197,7 +1197,7 @@ /* reap your zombies */ childaction.sa_handler=reap_children; #if defined(__GLIBC__) - __sigemptyset(&childaction.sa_mask); + sigemptyset(&childaction.sa_mask); #else /* __GLIBC__ */ childaction.sa_mask=0; #endif /* __GLIBC__ */ From b350aee4ea5785a75cb6ad770f6b768c506ebb70 Mon Sep 17 00:00:00 2001 From: Mike Frysinger Date: Mon, 14 Mar 2016 15:39:54 -0400 Subject: [PATCH] fix building w/newer glibc Linux C libraries are looking to disentangle sysmacros.h from the sys/types.h include, so make sure we pull in the header when it is found. --- src/daemon/open_console.c | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c index 4d6c0af..6dd43e6 100644 --- a/src/daemon/open_console.c +++ b/src/daemon/open_console.c @@ -24,6 +24,10 @@ #include /* major() */ #include /* ioctl */ +#ifdef HAVE_SYS_SYSMACROS_H +#include /* major() w/newer glibc */ +#endif + /* Linux specific (to be outsourced in gpm2 */ #include /* for serial console check */ #include /* for serial console check */ -- 2.6.2 hor
diff options
context:
space:
mode:
authorChristina O'Donnell <cdo@mutix.org>2024-03-16 10:26:05 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:40 +0000
commit18a77fb3f85423e351a99a916ec023024adfc49c (patch)
tree05f9c2845dda299b67b02367d1fe7ecf01eb9b50 /.gitignore
parentecdca86e1ce93ff22b0ad2c40b141b1b0d506418 (diff)
downloadguix-18a77fb3f85423e351a99a916ec023024adfc49c.tar.gz
guix-18a77fb3f85423e351a99a916ec023024adfc49c.zip
build-system/go: Add subdir parameter to go-version->git-ref.
This implements logic to handle cases where Go can have multiple modules at different versions within a single repository. It distinguishes their releases by using tags along with their subdirectories. See https://go.dev/ref/mod#vcs-version. * guix/build-system/go.scm (go-version->git-ref): Add <#:subdir> keyword parameter and extend condition checks. Change-Id: I68bc9e785e49877bb0b756de8458308549f4c957 Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to '.gitignore')
0 files changed, 0 insertions, 0 deletions