diff --git a/gourmet/backends/db.py b/gourmet/backends/db.py index faa6a57a..7e6d2bc6 100644 --- a/gourmet/backends/db.py +++ b/gourmet/backends/db.py @@ -773,9 +773,11 @@ class RecData (Pluggable): """Return the number of rows in table that match criteria """ if criteria: - return table.count(*make_simple_select_arg(criteria,table)).execute().fetchone()[0] + return sqlalchemy.select( + sqlalchemy.func.count(criteria)).select_from(table).scalar() else: - return table.count().execute().fetchone()[0] + return sqlalchemy.select( + sqlalchemy.func.count()).select_from(table).scalar() def fetch_join (self, table1, table2, col1, col2, column_names=None, sort_by=[], **criteria): Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nim.scm
AgeCommit message (Expand)Author
2023-06-06gnu: nim: Update to 1.6.12.Gruruya
2022-08-03gnu: nim: Enable parallel building.Efraim Flashner
2022-08-03gnu: nim: Patch dynamically loaded libraries.Efraim Flashner
2022-08-03gnu: nim: Prepare for running tests.Efraim Flashner
2022-08-03gnu: nim: Install shell completions.Efraim Flashner
2022-08-03gnu: nim: Build and install nimble.Trevor Richards
2022-07-03gnu: nim: Update to 1.6.6.Trevor Richards