--- a/girepository/gitypelib.c.orig +++ b/girepository/gitypelib.c @@ -2296,7 +2296,22 @@ _g_typelib_do_dlopen (GITypelib *typelib) { GModule *module; + /* 'gobject-introspection' doesn't store the path of shared + libraries into '.typelib' and '.gir' files. Shared + libraries are searched for in the dynamic linker search + path. In Guix we patch 'gobject-introspection' such that + it stores the absolute path of shared libraries in + '.typelib' and '.gir' files. Here, in order to minimize + side effects, we make sure that if the library is not + found at the indicated path location, we try with just + the basename and the system dynamic library + infrastructure, as per default behaviour of the + library. */ module = load_one_shared_library (shlibs[i]); + if (module == NULL && g_path_is_absolute (shlibs[i])) + { + module = load_one_shared_library (g_basename(shlibs[i])); + } if (module == NULL) { ctive' href='/guix/log/gnu/packages/rocm.scm'>logtreecommitdiff
path: root/gnu/packages/rocm.scm
00'>2023-03-28
AgeCommit message (Expand)Author
NEWS: Mention new rpm format....Maxim Cournoyer
2022-12-18Update NEWS.Ludovic Courtès
2022-12-17Update NEWS.Marius Bakke
2022-12-02Update NEWS.Ludovic Courtès
2022-11-23NEWS: Update it....Jonathan Brielmaier
2022-11-16Update NEWS.Maxim Cournoyer
2022-10-13NEWS: Update it....Mathieu Othacehe
2022-10-07Update NEWS....Maxim Cournoyer
2022-09-28Update NEWS....Mathieu Othacehe
2022-09-26NEWS: Update it....Mathieu Othacehe
2022-09-24Update NEWS.Ludovic Courtès
2022-09-23Update NEWS.Maxim Cournoyer
2022-09-19Update NEWS....Mathieu Othacehe
2022-09-16Update NEWS....Mathieu Othacehe
2022-09-15Update NEWS....Maxim Cournoyer
2022-09-14Update NEWS....Maxim Cournoyer