--- a/girepository/gitypelib.c.orig +++ b/girepository/gitypelib.c @@ -2296,7 +2296,22 @@ _g_typelib_do_dlopen (GITypelib *typelib) { GModule *module; + /* 'gobject-introspection' doesn't store the path of shared + libraries into '.typelib' and '.gir' files. Shared + libraries are searched for in the dynamic linker search + path. In Guix we patch 'gobject-introspection' such that + it stores the absolute path of shared libraries in + '.typelib' and '.gir' files. Here, in order to minimize + side effects, we make sure that if the library is not + found at the indicated path location, we try with just + the basename and the system dynamic library + infrastructure, as per default behaviour of the + library. */ module = load_one_shared_library (shlibs[i]); + if (module == NULL && g_path_is_absolute (shlibs[i])) + { + module = load_one_shared_library (g_basename(shlibs[i])); + } if (module == NULL) { a>treecommitdiff
path: root/NEWS
AgeCommit message (Expand)Author
2021-05-10Update NEWS.Maxim Cournoyer
2021-05-10Update NEWS.Leo Famulari
2021-05-10Update NEWS.Ludovic Courtès
2021-05-04Update NEWS.Ludovic Courtès
2020-11-22Update NEWS.Ludovic Courtès
2020-11-13Update NEWS.Ludovic Courtès
2020-11-09Update NEWS.Ludovic Courtès
2020-11-07Update NEWS.Mathieu Othacehe
2020-11-07Update NEWS.Ludovic Courtès
2020-11-05Update NEWS.Ludovic Courtès
2020-04-15Update NEWS.Ludovic Courtès
2020-04-12Update NEWS.Ludovic Courtès
2020-04-09Update NEWS.Ludovic Courtès