Use gcc as the default C compiler if CC is not set.
diff --git a/giscanner/__init__.py b/giscanner/__init__.py
index 7c2f365a..607fe341 100644
--- a/giscanner/__init__.py
+++ b/giscanner/__init__.py
@@ -21,6 +21,8 @@ import os
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
__path__.append(os.path.join(builddir, 'giscanner')) # type: ignore # mypy issue #1422
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'
try:
from ._version import __version__
except ImportError:
guix
|
Wojtek's customized Guix | |
Age | Commit message (Collapse) | Author |
|
* gnu/packages/certs.scm (nss-certs): Update to 3.99.
Change-Id: I588bc385022df486e596cd6fc5a7363df919b80b
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
|
* gnu/packages/certs.scm (nss-certs-3.98): New variable.
Change-Id: I95b54781c7b85f1d6b54158c6b906116791e009c
Signed-off-by: Andrew Tropin <andrew@trop.in>
|