Use gcc as the default C compiler if CC is not set. diff --git a/giscanner/__init__.py b/giscanner/__init__.py index 7c2f365a..607fe341 100644 --- a/giscanner/__init__.py +++ b/giscanner/__init__.py @@ -21,6 +21,8 @@ import os builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR') if builddir is not None: __path__.append(os.path.join(builddir, 'giscanner')) # type: ignore # mypy issue #1422 +if not 'CC' in os.environ: + os.environ['CC'] = 'gcc' try: from ._version import __version__ except ImportError: ass='form'>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/lint.scm
AgeCommit message (Expand)Author
2023-03-28Revert "lint: Append "/info/refs" to git-reference-url."...Maxim Cournoyer
2023-03-27lint: Append "/info/refs" to git-reference-url....Felix Lechner
2022-10-27gnu: python-setuptools: Move to python-build....Lars-Dominik Braun
2022-10-17lint: source: Add check for <svn-reference> over HTTP(S)....Ludovic Courtès
2022-03-29download: Use https for main KDE source....Efraim Flashner
2022-03-11lint: check-tests-true: Allow #:tests? #t for some build systems....Maxime Devos
2021-12-17lint: Adjust patch file length check....Vagrant Cascadian