# Names of libraries included in typelib files are opened by dlopen. Here we # add the full path. # # This patch was provided by Luca Bruno for # 'gobject-introspection' 1.40.0 in Nix. --- ./giscanner/utils.py.orig 2014-08-14 22:05:05.055334080 +0200 +++ ./giscanner/utils.py 2014-08-14 22:05:24.687497334 +0200 @@ -110,17 +110,11 @@ if dlname is None: return None - # Darwin uses absolute paths where possible; since the libtool files never - # contain absolute paths, use the libdir field - if platform.system() == 'Darwin': - dlbasename = os.path.basename(dlname) - libdir = _extract_libdir_field(la_file) - if libdir is None: - return dlbasename - return libdir + '/' + dlbasename - # From the comments in extract_libtool(), older libtools had - # a path rather than the raw dlname - return os.path.basename(dlname) + dlbasename = os.path.basename(dlname) + libdir = _extract_libdir_field(la_file) + if libdir is None: + return dlbasename + return libdir + '/' + dlbasename def extract_libtool(la_file): 721c9bdb2cf0576c715c'>refslogtreecommitdiff
path: root/po/doc/local.mk
AgeCommit message (Collapse)Author
2018-11-28nls: Update documentation po and pot with `make dist`.Julien Lepiller
* Makefile.am: dist-hook depends on doc-po-update. * po/doc/local.mk (doc-po-update): New target.
2018-11-01doc: Add German translation.Julien Lepiller
* doc/contributing.de.texi: New file. * doc/guix.de.texi: New file * doc/local.mk (TRANSLATED_INFO): Add them. (info_TEXINFOS): Add guix.de.texi. * po/doc/guix-manual.de.po: New file. * po/doc/local.mk (EXTRA_DIST): Add it. * doc/guix.texi: Document the German translation.
2018-04-29build: Use only one domain for guix-manual.Julien Lepiller
* Makefile.am (assert-no-store-file-names): Exclude guix-manual. * po/doc/guix.pot po/doc/contributing.pot: Merge into... * po/doc/guix-manual.pot: ...this. * po/doc/guix.fr.po po/doc/contributing.fr.po: Merge into... * po/doc/guix-manual.fr.po: ...this. * doc/local.mk: Replace old file names. * po/doc/local.mk: Replace old file names.
2018-04-19gnu: doc: Add French documentation.Julien Lepiller
* doc/contributing.fr.texi: New file. * doc/guix.fr.texi: New file. * doc/local.mk (TRANSLATED_INFO): Add them. (info_TEXINFOS): Add guix.fr.texi. * po/doc/contributing.fr.po: New file. * po/doc/guix.fr.po: New file. * po/doc/local.mk (EXTRA_DIST): Add them.
2018-04-19gnu: doc: Allow documentation to be translated.Julien Lepiller
* po/doc/contributing.pot: New file. * po/doc/guix.pot: New file. * po/doc/local.mk: New file. * Makefile.am: Include it. Add gettext command. Add silent rules for po4a. * configure.ac: Look for po4a-translate and po4a-updatepo. * doc/local.mk: Add rules to generate translated texi files. (TRANSLATED_INFO): New variable. (BUILT_SOURCES, EXTRA_DIST, MAINTAINERCLEANFILES): Add it. * .gitignore: Add generated files.