Make library/header paths visible to cmd/go script tests, which is necessary for
cgo/gccgo tests to work correctly
diff --git a/src/cmd/go/script_test.go b/src/cmd/go/script_test.go
index dfaa40548e..9d0f0e9bcd 100644
--- a/src/cmd/go/script_test.go
+++ b/src/cmd/go/script_test.go
@@ -100,6 +100,10 @@ const (
var extraEnvKeys = []string{
"SYSTEMROOT", // must be preserved on Windows to find DLLs; golang.org/issue/25210
"WINDIR", // must be preserved on Windows to be able to run PowerShell command; golang.org/issue/30711
+ "CPATH",
+ "C_INCLUDE_PATH",
+ "CPLUS_INCLUDE_PATH",
+ "LIBRARY_PATH",
"LD_LIBRARY_PATH", // must be preserved on Unix systems to find shared libraries
"CC", // don't lose user settings when invoking cgo
"GO_TESTING_GOTOOLS", // for gccgo testing
szko-scripts
Update email address for Amin Bandali....* .mailmap: Add name and email addresses for Amin Bandali.
* gnu/local.mk, gnu/packages/emacs-xyz.scm, gnu/packages/emacs.scm,
gnu/packages/fpga.scm, gnu/packages/lean.scm, gnu/packages/maths.scm:
Update email address for Amin Bandali.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Amin Bandali
2019-12-23
gnu: Add emacs-next....Add `emacs-next' for building latest Emacs from git.
* gnu/packages/emacs.scm (emacs-next): New variable.
(emacs): make the autoload deletion snippet not fail when eshell/esh-groups.el
does not exist. This enables reuse of the entire snippet field of `emacs' for
`emacs-next'.
* gnu/packages/patches/emacs27-exec-path.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add the above patch file to it.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
gnu: emacs: Reorder EMACSLOADPATH search path specification....Move Guix profiles' site-lisp before Emacs' own in the search path
specification, so that user installed packages can override Emacs' builtin
versions.
Fixes issue #38399 (see: https://bugs.gnu.org/38399).
Reported-by: Diego Nicola Barbato <dnbarbato@posteo.de>
* gnu/packages/emacs.scm (emacs): Move the Emacs builtin library directory
suffix to the end of the search path.
Maxim Cournoyer
2019-12-04
gnu: emacs: Simplify the EMACSLOADPATH search path specification....The EMACSLOADPATH can be greatly simplified by relying on a subdirs.el file
that causes Emacs to search recursively a directory found in EMACSLOADPATH.
* gnu/packages/emacs.scm (emacs)[native-search-paths]: Remove the match-all
file pattern regexp. Remove the versioned site-lisp directory from searched
files, as it appears unused by Emacs.
Reported-by: Leo Prikler <leo.prikler@student.tugraz.at>
Signed-off-by: Clément Lassieur <clement@lassieur.org>