Version 3.5.11 added a test to check that the default trust store is readable.
It does not exist in the build environment, so pretend everything is fine.
diff a/tests/trust-store.c b/tests/trust-store.c
--- a/tests/trust-store.c
+++ b/tests/trust-store.c
@@ -61,7 +61,7 @@
} else if (ret < 0) {
fail("error loading system trust store: %s\n", gnutls_strerror(ret));
} else if (ret == 0) {
- fail("no certificates were found in system trust store!\n");
+ success("no trust store in the Guix build environment!\n");
}
gnutls_certificate_free_credentials(x509_cred);
> : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-06-28 | gnu: jamvm-1-bootstrap: Add aarch64-linux support....* gnu/packages/java.scm (jamvm-1-bootstrap)[source]: Add patch; update
name of existing patch.
[arguments]<#:phases>: Invoke autoreconf during bootstrap phase when
building for aarch64.
[native-inputs]: Include packages required for autoreconf when
building for aarch64.
* gnu/packages/patches/jamvm-1.5.1-aarch64-support.patch: New file.
* gnu/packages/patches/jamvm-arm.patch: Rename to
"jamvm-1.5.1-armv7-support.patch".
* gnu/local.mk (dist_patch_DATA): Add file; update filename.
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Simon South |