Upstream status: Taken from Debian/upsream.
https://salsa.debian.org/hurd-team/gnumach/-/blob/master/debian/patches/90_noide.patch
This supports using `noide' on the gnumach command line, disabling
gnumach IDE support and thus forcing use of rumdisk.
---
linux/dev/glue/block.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
--- a/linux/dev/glue/block.c
+++ b/linux/dev/glue/block.c
@@ -207,7 +207,10 @@ int
blk_dev_init ()
{
#ifdef CONFIG_BLK_DEV_IDE
- ide_init ();
+ extern char *kernel_cmdline;
+ if (strncmp(kernel_cmdline, "noide", 5) &&
+ !strstr(kernel_cmdline, " noide"))
+ ide_init ();
#endif
#ifdef CONFIG_BLK_DEV_FD
floppy_init ();
a'/>
This patch make Xfce use "elementary-xfce-dark" as the default icon theme, "Greybird" as
the default GTK theme and enable font antialias.
--- xfce4-settings-4.20.0/xfsettingsd/xsettings.xml.orig 2024-12-20 09:53:09.518493612 +0800
+++ xfce4-settings-4.20.0/xfsettingsd/xsettings.xml 2024-12-20 09:55:15.506496473 +0800
@@ -6,8 +6,8 @@
<channel name="xsettings" version="1.0">
<property name="Net" type="empty">
- <property name="ThemeName" type="string" value="Adwaita"/>
- <property name="IconThemeName" type="string" value="Adwaita"/>
+ <property name="ThemeName" type="string" value="Greybird"/>
+ <property name="IconThemeName" type="string" value="elementary-xfce-dark"/>
<property name="DoubleClickTime" type="int" value="400"/>
<property name="DoubleClickDistance" type="int" value="5"/>
<property name="DndDragThreshold" type="int" value="8"/>
@@ -19,9 +19,9 @@
</property>
<property name="Xft" type="empty">
<property name="DPI" type="int" value="-1"/>
- <property name="Antialias" type="int" value="-1"/>
+ <property name="Antialias" type="int" value="1"/>
<property name="Hinting" type="int" value="-1"/>
- <property name="HintStyle" type="string" value="hintnone"/>
+ <property name="HintStyle" type="string" value="hintfull"/>
<property name="RGBA" type="string" value="none"/>
</property>
<property name="Gtk" type="empty">