Upstream status: Taken from Debian/upsream. https://salsa.debian.org/hurd-team/gnumach/-/blob/master/debian/patches/90_noide.patch This supports using `noide' on the gnumach command line, disabling gnumach IDE support and thus forcing use of rumdisk. --- linux/dev/glue/block.c | 5 ++++- 1 file changed, 4 insertions(+), 1 deletion(-) --- a/linux/dev/glue/block.c +++ b/linux/dev/glue/block.c @@ -207,7 +207,10 @@ int blk_dev_init () { #ifdef CONFIG_BLK_DEV_IDE - ide_init (); + extern char *kernel_cmdline; + if (strncmp(kernel_cmdline, "noide", 5) && + !strstr(kernel_cmdline, " noide")) + ide_init (); #endif #ifdef CONFIG_BLK_DEV_FD floppy_init (); Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/marionette.scm
AgeCommit message (Expand)Author
2020-02-22marionette: Provide portable US-layout keystrokes for "<" and ">"....* gnu/build/marionette.scm (%qwerty-us-keystrokes): Use shit-comma and shift-dot for #\< and #\> because the "less" key doesn't work the same in "US intl." layouts. Ludovic Courtès
2020-02-22marionette: 'wait-for' procedures no longer leak a port....* gnu/build/marionette.scm (wait-for-tcp-port): Close SOCK upon success. (wait-for-unix-socket): Likewise. Ludovic Courtès
2019-05-15marionette: Add braces to the keystrokes....* gnu/build/marionette.scm (%qwerty-us-keystrokes): Add braces. Ludovic Courtès
2018-08-28marionette: Add wait-for-unix-socket....* gnu/build/marionette.scm (wait-for-unix-socket): New variable. Chris Marusich
2018-08-28marionette: Add support for QEMU's "quit" command....* gnu/build/marionette.scm (marionette-control): Don't wait for the monitor prompt when the command was "quit". Chris Marusich
2018-06-01marionette: Add 'wait-for-tcp-port'....* gnu/build/marionette.scm (wait-for-tcp-port): New procedure. * gnu/tests/dict.scm (run-dicod-test)["connect inside"]: Use it instead of the inline loop. Ludovic Courtès
2018-02-19marionette: Use QEMU's "VM channel" mechanism....* gnu/tests.scm (<marionette-configuration>)[device]: Default to "/dev/virtio-ports/org.gnu.guix.port.0". * gnu/tests.scm (marionette-shepherd-service): Remove (guix build syscalls) from 'modules'. Remove 'tcsetattr' call from 'start'. * gnu/build/marionette.scm (make-marionette): Use "-virtserialport" instead of "-virtconsole". Ludovic Courtès