Gnome-tweaks does not look at GSETTINGS_SCHEMA_PATH or XDG_DATA_DIRS, it assumes that schemas are installed in one global directory (GSETTINGS_SCHEMA_DIR/gsettingsschemadir). Guix/GuixSD uses a different directory for every gir package and has packages pick-up files using XDG_DATA_DIRS. Upstream ticket: https://bugzilla.gnome.org/show_bug.cgi?id=764537 janneke@gnu.org --- gnome-tweak-3.18.1.orig/gtweak/gsettings.py 2015-04-08 15:21:32.000000000 +0200 +++ gnome-tweak-tool-3.18.1/gtweak/gsettings.py 2016-04-03 11:26:38.658482704 +0200 @@ -16,7 +16,8 @@ # along with gnome-tweak-tool. If not, see . import logging -import os.path +import os +import sys import xml.dom.minidom import gettext @@ -31,6 +32,13 @@ class GSettingsMissingError(Exception): pass +def file_from_path(path, file_name): + for dir in path: + f = os.path.join(dir, file_name) + if os.path.exists(f): + return f + return None + class _GSettingsSchema: def __init__(self, schema_name, schema_dir=None, schema_filename=None, **options): if not schema_dir: @@ -38,9 +46,14 @@ if
aboutsummaryrefslogtreecommitdiff
path: root/scheduler.h
diff options
context:
space:
mode:
authorWojtek Kosior <kwojtus@protonmail.com>2020-01-02 13:45:41 +0100
committerWojtek Kosior <kwojtus@protonmail.com>2020-01-02 13:45:41 +0100
commit03e9c87115527eeb21d5c7c554c3a1b6f8211e54 (patch)
tree602190ded1f65961336e0ed12b9261f5bdc178bc /scheduler.h
parent7da46d099e1d1909bf5d09ecedfea21481a7a3b9 (diff)
downloadrpi-MMU-example-03e9c87115527eeb21d5c7c554c3a1b6f8211e54.tar.gz
rpi-MMU-example-03e9c87115527eeb21d5c7c554c3a1b6f8211e54.zip
fix/improve arm timer register definitions
Diffstat (limited to 'scheduler.h')