Gnome-tweaks does not look at GSETTINGS_SCHEMA_PATH or XDG_DATA_DIRS, it assumes that schemas are installed in one global directory (GSETTINGS_SCHEMA_DIR/gsettingsschemadir). Guix/GuixSD uses a different directory for every gir package and has packages pick-up files using XDG_DATA_DIRS. Upstream ticket: https://bugzilla.gnome.org/show_bug.cgi?id=764537 janneke@gnu.org --- gnome-tweak-3.18.1.orig/gtweak/gsettings.py 2015-04-08 15:21:32.000000000 +0200 +++ gnome-tweak-tool-3.18.1/gtweak/gsettings.py 2016-04-03 11:26:38.658482704 +0200 @@ -16,7 +16,8 @@ # along with gnome-tweak-tool. If not, see . import logging -import os.path +import os +import sys import xml.dom.minidom import gettext @@ -31,6 +32,13 @@ class GSettingsMissingError(Exception): pass +def file_from_path(path, file_name): + for dir in path: + f = os.path.join(dir, file_name) + if os.path.exists(f): + return f + return None + class _GSettingsSchema: def __init__(self, schema_name, schema_dir=None, schema_filename=None, **options): if not schema_dir: @@ -38,9 +46,14 @@ if not schema_filename: schema_filename = schema_name + ".gschema.xml" + schema_prefix = os.path.join('glib-2.0', 'schemas') schema_path = os.path.join(schema_dir, schema_filename) if not os.path.exists(schema_path): - logging.critical("Could not find schema %s" % schema_path) + schema_path = file_from_path(os.environ.get ('GSETTINGS_SCHEMA_PATH', '').split(os.path.pathsep), schema_filename) + if not (schema_path and os.path.exists(schema_path)): + schema_path = file_from_path(os.environ.get ('XDG_DATA_DIRS', '').split(os.path.pathsep), os.path.join(schema_prefix, schema_filename)) + if not (schema_path and os.path.exists(schema_path)): + logging.critical("Could not find schema %s" % schema_filename) assert(False) self._schema_name = schema_name '>root/gnu/tests.scm
AgeCommit message (Expand)Author
2018-08-29tests: Warn about test module load failures....Ludovic Courtès
2018-05-28system: Remove uses of the 'title' field of <file-system>....Ludovic Courtès
2018-02-19marionette: Use QEMU's "VM channel" mechanism....Ludovic Courtès
2018-01-09tests: marionette-operating-system: Add initrd parameter and kernel-arguments....Danny Milosavljevic
2017-12-06gnu, doc, tests: Use ‘bootloader-configuration’ everywhere....Tobias Geerinckx-Rice
2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe
2017-05-04tests: Use 'fold-module-public-variables' for discovery....Ludovic Courtès
2017-05-03Add (guix discovery)....Ludovic Courtès
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès