This patch adds a "guix gc" button to the low disk space notification that 'gsd-housekeeping' emits. diff --git a/plugins/housekeeping/gsd-disk-space.c b/plugins/housekeeping/gsd-disk-space.c index bd3437e..89027d8 100644 --- a/plugins/housekeeping/gsd-disk-space.c +++ b/plugins/housekeeping/gsd-disk-space.c @@ -546,6 +546,21 @@ empty_trash_callback (NotifyNotification *n, notify_notification_close (n, NULL); } +static void +guix_gc_callback (NotifyNotification *n, + const char *action) +{ + const gchar *argv[] = { "guix", "gc", NULL }; + + g_assert (action != NULL); + g_assert (strcmp (action, "run-guix-gc") == 0); + + g_spawn_async (NULL, (gchar **) argv, NULL, G_SPAWN_SEARCH_PATH, + NULL, NULL, NULL, NULL); + + notify_notification_close (n, NULL); +} + static void on_notification_closed (NotifyNotification *n) { @@ -591,6 +606,13 @@ ldsm_notify (const char *summary, g_free); } + notify_notification_add_action (notification, + "run-guix-gc", + _("Collect Unused Guix Items"), + (NotifyActionCallback) guix_gc_callback, + NULL, + NULL); + has_trash = ldsm_mount_has_trash (mount_path); if (has_trash) { ef='/guix/diff/gnu/packages/busybox.scm?id=b114aba2840a878ba64e5f9cd8056636885ba457'>diff
path: root/gnu/packages/busybox.scm
AgeCommit message (Collapse)Author
2018-12-12gnu: Add toybox.Efraim Flashner
* gnu/packages/busybox.com (toybox): New variable.
2018-09-18gnu: busybox: Update to 1.29.3.Tobias Geerinckx-Rice
* gnu/packages/busybox.scm (busybox): Update to 1.29.3.
2018-07-19gnu: busybox: Update to 1.29.1.Efraim Flashner
* gnu/packages/busybox.scm (busybox): Update to 1.29.1. [arguments]: Add custom phase to change the default value of TASKSET.
2018-06-22gnu: busybox: Return #t from all phases.Tobias Geerinckx-Rice
* gnu/packages/busybox.scm (busybox)[arguments]: Substitute INVOKE for SYSTEM*.
2017-06-21gnu: busybox: Fix indentation.Efraim Flashner
* gnu/packages/busybox.scm (busybox)[arguments]: Whitespace changes.
2017-06-21gnu: busybox: Update to 1.26.2.Efraim Flashner
* gnu/packages/busybox.scm (busybox): Update to 1.26.2.
2017-06-20gnu: Move contents of zip module into compression module.Arun Isaac
* gnu/packages/zip.scm (zip, unzip, zziplib, perl-zip): Move to... * gnu/packages/compression.scm: ...here. * gnu/packages/zip.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Unregister deleted file. * po/packages/POTFILES.in: Unregister deleted file. * gnu/packages/{audio, avr, bioinformatics, busybox, cdrom, ci, compression, docbook, documentation, fonts, fpga, game-development, games, gl, gnome, gnuzilla, graphics, guile, haskell, image, java, kodi, ldc, libreoffice, markup, maths, mc, monitoring, music, php, pretty-print, python, scheme, smalltalk, statistics, synergy, tex, textutils, video, web-browsers, xml, zip}.scm, guix/build-system/{ant, font}.scm, guix/{download, packages}.scm: Adapt module import.