This patch adds a "guix gc" button to the low disk space notification that 'gsd-housekeeping' emits. diff --git a/plugins/housekeeping/gsd-disk-space.c b/plugins/housekeeping/gsd-disk-space.c index bd3437e..89027d8 100644 --- a/plugins/housekeeping/gsd-disk-space.c +++ b/plugins/housekeeping/gsd-disk-space.c @@ -546,6 +546,21 @@ empty_trash_callback (NotifyNotification *n, notify_notification_close (n, NULL); } +static void +guix_gc_callback (NotifyNotification *n, + const char *action) +{ + const gchar *argv[] = { "guix", "gc", NULL }; + + g_assert (action != NULL); + g_assert (strcmp (action, "run-guix-gc") == 0); + + g_spawn_async (NULL, (gchar **) argv, NULL, G_SPAWN_SEARCH_PATH, + NULL, NULL, NULL, NULL); + + notify_notification_close (n, NULL); +} + static void on_notification_closed (NotifyNotification *n) { @@ -591,6 +606,13 @@ ldsm_notify (const char *summary, g_free); } + notify_notification_add_action (notification, + "run-guix-gc", + _("Collect Unused Guix Items"), + (NotifyActionCallback) guix_gc_callback, + NULL, + NULL); + has_trash = ldsm_mount_has_trash (mount_path); if (has_trash) { diff
path: root/gnu/packages/ibus.scm
AgeCommit message (Expand)Author
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-11-23Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-21gnu: ibus-theme-tools: Do not delete check phase....Liliana Marie Prikler
2021-11-21gnu: Add ibus-theme-tools....Songlin Jiang
2021-09-07gnu: librime: Fix build with GCC 10....Felix Gruber
2021-08-12Merge branch 'master' into core-updates-frozen...Marius Bakke
2021-08-05gnu: ibus-rime: Update to 1.5.0....Peng Mei Yu
2021-08-05gnu: rime-data: Update to 0.38.20210802....Peng Mei Yu
2021-08-05gnu: librime: Update to 1.7.3....Peng Mei Yu
2021-07-24gnu: Use 'search-input-file' when looking for executables....Ludovic Courtès