This fixes whereby, on 32-bit platforms, libc 2.22 would fail to pass O_LARGEFILE to 'openat'. This was caught by 'tests/sparse03.at' in the tar test suite. commit eb32b0d40308166c4d8f6330cc2958cb1e545075 Author: Andreas Schwab Date: Mon Aug 10 14:12:47 2015 +0200 Readd O_LARGEFILE flag for openat64 (bug 18781) --- a/sysdeps/unix/sysv/linux/openat.c +++ b/sysdeps/unix/sysv/linux/openat.c @@ -68,6 +68,11 @@ __OPENAT (int fd, const char *file, int oflag, ...) va_end (arg); } + /* We have to add the O_LARGEFILE flag for openat64. */ +#ifdef MORE_OFLAGS + oflag |= MORE_OFLAGS; +#endif + return SYSCALL_CANCEL (openat, fd, file, oflag, mode); } libc_hidden_def (__OPENAT) '>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2019-02-28gnu: groff: Return #t from all phases....* gnu/packages/groff.scm (groff)[arguments]: Return #t from phases. Marius Bakke
2019-02-28gnu: groff: Adjust relocatability snippet for 1.22.4....This commit does three things. It reverts 73b2ce87 ("gnu: groff-minimal: Disable relocatability."), re-applies f57693e1 ("gnu: groff: Disable relocatability."), and finally adjusts the substitution for changes since 0559a4c2 ("gnu: groff: Update to 1.22.4."). * gnu/packages/groff.scm (groff-minimal)[arguments]: Move relocatibility snippet ... (groff)[arguments]: ... here. Don't delete relocation.cpp and adjust file name. Marius Bakke
2019-02-06Merge branch 'master' into core-updatesRicardo Wurmus
2019-01-17gnu: groff-minimal: Disable relocatability....* gnu/packages/groff.scm (groff-minimal)[arguments]<#:phases> [disable-relocatability]: New phase. Danny Milosavljevic
2019-01-16Revert "gnu: groff: Disable relocatability."...This causes more than 3600 packages to be rebuilt. This reverts commit f57693e17c7905d2f11e46d04cb558fe0b0fc39b. Efraim Flashner
2019-01-16gnu: groff: Disable relocatability....* gnu/packages/groff.scm (groff)[arguments]<#:phases>[disable-relocatability]: New phase. Danny Milosavljevic
2019-01-14gnu: groff: Fix doc installation....* gnu/packages/groff.scm (groff)[arguments]: Add 'fix-docdir phase. Eric Bavier
2019-01-07gnu: groff: Update to 1.22.4....* gnu/packages/groff.scm (groff): Update to 1.22.4. [source]: Remove patch. (groff-minimal)[arguments]: Update configure flags to skip documentation. * gnu/packages/patches/groff-source-date-epoch.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner