This fixes whereby, on 32-bit platforms, libc 2.22 would fail to pass O_LARGEFILE to 'openat'. This was caught by 'tests/sparse03.at' in the tar test suite. commit eb32b0d40308166c4d8f6330cc2958cb1e545075 Author: Andreas Schwab Date: Mon Aug 10 14:12:47 2015 +0200 Readd O_LARGEFILE flag for openat64 (bug 18781) --- a/sysdeps/unix/sysv/linux/openat.c +++ b/sysdeps/unix/sysv/linux/openat.c @@ -68,6 +68,11 @@ __OPENAT (int fd, const char *file, int oflag, ...) va_end (arg); } + /* We have to add the O_LARGEFILE flag for openat64. */ +#ifdef MORE_OFLAGS + oflag |= MORE_OFLAGS; +#endif + return SYSCALL_CANCEL (openat, fd, file, oflag, mode); } libc_hidden_def (__OPENAT) ption value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-26 21:35:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-26 23:13:54 +0100
commit68631e037bd79039b5b14150e01f64cd8f81eabb (patch)
treee915b9cdf73b61600416ac24d9e16f83911048e6 /gnu/packages/engineering.scm
parent4b81d5c4bc442a12c681586f6c25a4ca0af44056 (diff)
downloadguix-68631e037bd79039b5b14150e01f64cd8f81eabb.tar.gz
guix-68631e037bd79039b5b14150e01f64cd8f81eabb.zip
gnu: ldc: Use INVOKE.
* gnu/packages/dlang.scm (ldc)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/engineering.scm')
0 files changed, 0 insertions, 0 deletions