This fixes whereby, on 32-bit platforms, libc 2.22 would fail to pass O_LARGEFILE to 'openat'. This was caught by 'tests/sparse03.at' in the tar test suite. commit eb32b0d40308166c4d8f6330cc2958cb1e545075 Author: Andreas Schwab Date: Mon Aug 10 14:12:47 2015 +0200 Readd O_LARGEFILE flag for openat64 (bug 18781) --- a/sysdeps/unix/sysv/linux/openat.c +++ b/sysdeps/unix/sysv/linux/openat.c @@ -68,6 +68,11 @@ __OPENAT (int fd, const char *file, int oflag, ...) va_end (arg); } + /* We have to add the O_LARGEFILE flag for openat64. */ +#ifdef MORE_OFLAGS + oflag |= MORE_OFLAGS; +#endif + return SYSCALL_CANCEL (openat, fd, file, oflag, mode); } libc_hidden_def (__OPENAT) szko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2019-05-05gnu: tor: Remove explicit hardening flags....Tobias Geerinckx-Rice
2019-05-03gnu: tor: Update to 0.4.0.5....Tobias Geerinckx-Rice
2019-03-18Correct name and email address for ng0....ng0
2019-02-21gnu: tor: Update to 0.3.4.11 [fixes TROVE-2019-001]....Tobias Geerinckx-Rice
2019-02-18gnu: onionshare: Update to 1.3.2....Tobias Geerinckx-Rice
2019-02-08gnu: torsocks: Update to 2.3.0....Tobias Geerinckx-Rice
2019-02-08gnu: torsocks: Don't use NAME in source URI....Tobias Geerinckx-Rice
2019-02-05gnu: nyx: Update to 2.1.0....Tobias Geerinckx-Rice
2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus
2019-01-08gnu: tor: Update to 0.3.4.10....Tobias Geerinckx-Rice
2019-01-08gnu: privoxy: Update to 3.0.28....Tobias Geerinckx-Rice
2018-12-12gnu: onionshare: Update to 1.3.1....Eric Bavier
2018-11-29gnu: onionshare: Fetch sources from git....Ricardo Wurmus
2018-11-11gnu: privoxy: Remove custom bootstrap phase....Ricardo Wurmus
2018-11-02gnu: tor: Update to 0.3.4.9....Tobias Geerinckx-Rice
2018-09-10gnu: tor: Update to 0.3.4.8....Tobias Geerinckx-Rice