This patch allows us to use glibc's build system to build locales
in a package separate from glibc.
1. Use 'localedef' from $PATH since we are not rebuilding it.
2. Use '--no-archive' to avoid building the big locale archive, and
because the already-built 'localedef' would want to write it
to '/run/current-system/locale', which is not possible.
3. Pass $(inst_complocaledir)/$$locale to install files in the right
place, and because otherwise, 'localedef' fails with:
"cannot write output files to `(null)'".
diff -ru glibc-2.29-old/localedata/Makefile glibc-2.29-new/localedata/Makefile
--- glibc-2.29-old/localedata/Makefile 2019-01-31 11:45:36.000000000 -0500
+++ glibc-2.29-new/localedata/Makefile 2019-07-03 22:48:35.662015071 -0400
@@ -385,7 +385,7 @@
# Sometimes the whole collection of locale files should be installed.
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
-$(rtld-prefix) $(common-objpfx)locale/localedef
+ localedef --no-archive
install-locales: install-locale-archive
# Create and install the locale-archive file.
@@ -414,7 +414,7 @@
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
$(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \
-i locales/$$input -f charmaps/$$charset \
- $(addprefix --prefix=,$(install_root)) $$locale \
+ $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \
&& echo ' done';
endef
/packages/code.scm?id=828ceee7db0ab74786049600108d6b15017851c5'>diff
|
Age | Commit message (Expand) | Author |
2021-05-18 | gnu: universal-ctags: Update to 5.9.20210509.0....* gnu/packages/code.scm (universal-ctags): Update to 5.9.20210509.0.
[source](snippet): Adjust unbundling substitution.
[arguments]: Add #:test-target. Patch more files before bootstrapping.
Remove trailing #t's.
[native-inputs]: Use PACKCC instead of an ad-hoc fork.
| Marius Bakke |
2021-05-02 | gnu: global: Update to 6.6.6....* gnu/packages/code.scm (global): Update to 6.6.6.
| Tobias Geerinckx-Rice |
2021-05-02 | gnu: cloc: Update to 1.90....* gnu/packages/code.scm (cloc): Update to 1.90.
| Tobias Geerinckx-Rice |
2021-04-28 | gnu: global: Fix cross compiling....Coreutils was removed during patch review erroneously.
Reported by Maxime Devos <maximedevos@telenet.be>.
* gnu/packages/code.scm (global)[inputs]: Add coreutils.
| Efraim Flashner |
2021-04-28 | gnu: global: Fix globash....* gnu/packages/code.scm (global)[arguments]: Add 'fix-globash phase.
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| luhui |
2021-04-05 | gnu: sloccount: Update source URL....* gnu/packages/code.scm (sloccount)[source, home-page]: Update.
| Ludovic Courtès |