This patch allows us to use glibc's build system to build locales in a package separate from glibc. 1. Use 'localedef' from $PATH since we are not rebuilding it. 2. Use '--no-archive' to avoid building the big locale archive, and because the already-built 'localedef' would want to write it to '/run/current-system/locale', which is not possible. 3. Pass $(inst_complocaledir)/$$locale to install files in the right place, and because otherwise, 'localedef' fails with: "cannot write output files to `(null)'". --- glibc-2.27/localedata/Makefile +++ glibc-2.27/localedata/Makefile @@ -199,7 +199,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES)) # Sometimes the whole collection of locale files should be installed. LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \ -$(rtld-prefix) $(common-objpfx)locale/localedef + localedef --no-archive install-locales: $(INSTALL-SUPPORTED-LOCALES) install-locales-dir: @@ -224,7 +224,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \ $(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \ -i locales/$$input -f charmaps/$$charset \ - $(addprefix --prefix=,$(install_root)) $$locale \ + $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \ && echo ' done'; \ tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP iff/tests/profiles.scm?id=de194a39d3d49c7424d08e04b675ff649035e7b1'>diff
path: root/tests/profiles.scm
AgeCommit message (Expand)Author
2020-12-07profiles: Delete duplicate manifest entries in packages->manifest....Leo Prikler
2020-12-07profiles: Remove duplicates in manifest transactions....Leo Prikler
2020-04-26profiles: Add lowerable <profile> record type....Ludovic Courtès
2019-11-22profiles: Add 'concatenate-manifests'....Ludovic Courtès
2019-06-14tests: Make builds less expensive....Ludovic Courtès
2019-02-07profiles: Raise an error for unmatched patterns....Ludovic Courtès
2019-01-20profiles: Allow a profile to be added as an entry of another profile....Ludovic Courtès
2019-01-20tests: Adjust to python.scm split....Ludovic Courtès
2018-11-12tests: Add 'test-assertm' to (guix tests)....Ludovic Courtès
2018-09-11profiles: Correctly deal with etc/ being a relative symlink....Ludovic Courtès