This patch allows us to use glibc's build system to build locales in a package separate from glibc. 1. Use 'localedef' from $PATH since we are not rebuilding it. 2. Use '--no-archive' to avoid building the big locale archive, and because the already-built 'localedef' would want to write it to '/run/current-system/locale', which is not possible. 3. Pass $(inst_complocaledir)/$$locale to install files in the right place, and because otherwise, 'localedef' fails with: "cannot write output files to `(null)'". diff -ru glibc-2.29-old/localedata/Makefile glibc-2.29-new/localedata/Makefile --- glibc-2.29-old/localedata/Makefile 2019-01-31 11:45:36.000000000 -0500 +++ glibc-2.29-new/localedata/Makefile 2019-07-03 22:48:35.662015071 -0400 @@ -385,7 +385,7 @@ # Sometimes the whole collection of locale files should be installed. LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \ -$(rtld-prefix) $(common-objpfx)locale/localedef + localedef --no-archive install-locales: install-locale-archive # Create and install the locale-archive file. @@ -414,7 +414,7 @@ input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \ $(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \ -i locales/$$input -f charmaps/$$charset \ - $(addprefix --prefix=,$(install_root)) $$locale \ + $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \ && echo ' done'; endef /services/sddm.scm?id=e930d4a747d319b559dacb55211764ee680c11d9'>diff
path: root/gnu/services/sddm.scm
AgeCommit message (Expand)Author
2020-11-18services: SDDM: Wait for elogind before starting....Marius Bakke
2020-04-19services: sddm: Have sddm provision xorg-server....Efraim Flashner
2020-03-01services: set-xorg-configuration: handle slim and sddm...Jakub Kądziołka
2020-02-16doc: Fix typo....Efraim Flashner
2019-10-21services: sddm: Add description....Ludovic Courtès
2019-10-21services: sddm: Deprecate 'sddm-service' procedure....Ludovic Courtès
2019-10-21services: sddm: Add default configuration....Brendan Tildesley
2019-05-26services: sddm: Fix root login failure issue....Reza Alizadeh Majd
2019-04-11services: sddm: Switch back to using ‘startx’....frozenpigs
2019-03-25services: SDDM: Specify absolute path to the X server....Marius Bakke
2019-03-24services: sddm, slim, gdm: Take an <xorg-configuration> record....Ludovic Courtès