This patch allows us to use glibc's build system to build locales
in a package separate from glibc.
1. Use 'localedef' from $PATH since we are not rebuilding it.
2. Use '--no-archive' to avoid building the big locale archive, and
because the already-built 'localedef' would want to write it
to '/run/current-system/locale', which is not possible.
3. Pass $(inst_complocaledir)/$$locale to install files in the right
place, and because otherwise, 'localedef' fails with:
"cannot write output files to `(null)'".
--- glibc-2.27/localedata/Makefile
+++ glibc-2.27/localedata/Makefile
@@ -199,7 +199,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
# Sometimes the whole collection of locale files should be installed.
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
-$(rtld-prefix) $(common-objpfx)locale/localedef
+ localedef --no-archive
install-locales: $(INSTALL-SUPPORTED-LOCALES)
install-locales-dir:
@@ -224,7 +224,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
$(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \
-i locales/$$input -f charmaps/$$charset \
- $(addprefix --prefix=,$(install_root)) $$locale \
+ $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \
&& echo ' done'; \
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP
ommitdiff
|
Age | Commit message (Expand) | Author |
2024-09-16 | gnu: hunspell-dict-el: Add a source file-name....* gnu/packages/hunspell.scm (hunspell-dict-el)[source]: Add a file-name
field.
Change-Id: Ibdc1ba7acf73c33f3bbaee888cd170b6aa4962af
| Efraim Flashner |
2024-09-16 | gnu: hunspell-dict-el: Reflow with guix style....* gnu/packages/hunspell.scm (hunspell-dict-el): Reformat package
definition using 'guix style'.
Change-Id: Ifd741ec3aea6a25b3c2fecdb0d21caf8d5f59b94
| Efraim Flashner |
2024-08-21 | gnu: hunspell: Add Greek dictionary....* gnu/packages/hunspell.scm (hunspell-dict-el): New variable.
Change-Id: I5b534862030a60e09f2c4a741a723fc2467b20ba
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
| Thanos Apollo |
2024-06-13 | gnu: libreoffice: Update to 7.6.7.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 7.6.7.2.
* gnu/packages/hunspell.scm (hunspell-dict-he-il,
hunspell-dict-it-it): Update to 7.6.7.2.
Change-Id: I289a0b2b9648930b46102c055c642c333a4229fd
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Nicolas Graves |